The entire contact list on a SIM get loaded each time you type N(N)(N)# on the keypad

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jlorenzo, Assigned: thills)

Tracking

({late-l10n})

unspecified
2.2 S7 (6mar)
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(4 attachments)

Reporter

Description

4 years ago
Pre-requisites
Have some contacts present in the SIM.

STR
1. Tap 1# on the dialer keypad.
2. See the "loading contacts..." window and wait until it disappears.
3. Clear the displayed phone number an tap 1# again

Expected results
As a user, when I read "loading contacts" I would expect to not see this window again in step 3.

Actual results
You get this window again and wait exactly the same time to get a phone number. We have either a wording issue ("Searching the contact in your SIM..." would be more appropriate) or an optimization problem. The second option looks more probable as we retrieve the entire contact list each time [1].

[1] https://github.com/mozilla-b2g/gaia/commit/5feeecad9d1215bcc61b99a7dfe828c102bdf7d7#diff-98e96f21adf938206005ba91e4984e69R563
Reporter

Comment 1

4 years ago
[Blocking Requested - why for this release]: New functionality which has either a wording problem or an optimization one. Leaving it in the current state would provide a bad experience.
blocking-b2g: --- → 2.2?
Reporter

Comment 2

4 years ago
Like discussed on IRC during the Dialer stand up, this behavior is by design as we don't have a way to get notified when a contact changes on the SIM.

We need to change the message before String Freeze though. Delphine, per FxOS QA's calendar, it seems that String Freeze will happen at the same time as Feature Complete. Is that correct?
Flags: needinfo?(lebedel.delphine)
Correct. However please note that after Feature Landing (Feb 23), any string changes will need approval from RelMan and l10n team. 
If a patch that implies string modification is accepted and lands after Feature Landing (Feb. 23rd), please remember to add the late-l10n keyword. thanks!
Flags: needinfo?(lebedel.delphine)
Reporter

Comment 4

4 years ago
Triage: Depending on bug 1131261 comment 12, this bug needs either to be fixed or bug 1061130 to be backed out.
Reporter

Comment 5

4 years ago
See bug 1131261 comment 14.
blocking-b2g: 2.2? → 2.2+
We will change this string to "Loading SIM card contacts".
Assignee: nobody → thills
Target Milestone: --- → 2.2 S6 (20feb)
Assignee

Updated

4 years ago
Status: NEW → ASSIGNED
Assignee

Comment 8

4 years ago
Attachment #8566159 - Flags: review?(drs.bugzilla)
Comment on attachment 8566159 [details] [review]
PR with string change

Anytime we make a string change, we must change the key as well. This is so that the l10n team knows that a change has been made. We also shouldn't be changing this key just for this purpose anyways, since it is used elsewhere.
Attachment #8566159 - Flags: review?(drs.bugzilla) → review-
Assignee

Comment 10

4 years ago
Posted file Updated PR
Hi Doug,

I added a new string into the dialer properties as opposed to contacts.  I left the old one as-is.

-tamara
Attachment #8566499 - Flags: review?(drs.bugzilla)
I suggest putting the string in apps/communications/dialer/locales/shared.en-US.properties since it's used from the shared keypad sources.
Comment on attachment 8566499 [details] [review]
Updated PR

(In reply to Gabriele Svelto [:gsvelto] from comment #11)
> I suggest putting the string in
> apps/communications/dialer/locales/shared.en-US.properties since it's used
> from the shared keypad sources.

Actually, I'd recommend putting it in |shared/locales/keypad/keypad.en-US.properties| instead.
Attachment #8566499 - Flags: review?(drs.bugzilla) → review-
Assignee

Comment 13

4 years ago
Comment on attachment 8566499 [details] [review]
Updated PR

Hi Doug,

I updated the PR and moved the new string to |shared/locales/keypad/keypad.en-US.properties| per ur suggestion.

Thanks,

-tamara
Attachment #8566499 - Flags: review- → review?(drs.bugzilla)
Comment on attachment 8566499 [details] [review]
Updated PR

Sorry to r- again, but this needs a test. See the PR.
Attachment #8566499 - Flags: review?(drs.bugzilla) → review-
Assignee

Updated

4 years ago
Attachment #8566499 - Flags: review- → review?(drs.bugzilla)
(In reply to Doug Sherk (:drs) (use needinfo?) from comment #12)
> Actually, I'd recommend putting it in
> |shared/locales/keypad/keypad.en-US.properties| instead.

Good point, shared is shared :)
Attachment #8566499 - Flags: review?(drs.bugzilla) → review+
Not sure if someone can land a quick follow-up, but can you please replace "..." with a proper "…"? That's the standard for en-US on Gaia (and in general in Mozilla products).
(In reply to Francesco Lodolo [:flod] from comment #17)
> Not sure if someone can land a quick follow-up, but can you please replace
> "..." with a proper "…"? That's the standard for en-US on Gaia (and in
> general in Mozilla products).

I'm doing more changes to this code in bug 1131261 which also has new strings so I can do that there too.
Comment on attachment 8566499 [details] [review]
Updated PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1061130
[User impact] if declined: The message shown when doing a speed dial operation is unclear
[Testing completed]: Tested on a device, unit-test added
[Risk to taking this patch] (and alternatives if risky): No risks involved
[String changes made]: `loadingSimContacts` added to the shared/locales/keypad/keypad.en-US.properties file
Attachment #8566499 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8566499 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This bug has been verified as "pass" on latest nightly build of Flame v2.2&Master by the STR in comment 0.

Actual results: The string "Loading SIM card contacts..." shows when doing a speed dial operation as expected.
See attachment: verified_Flame_v2.2.png
Reproduce rate: 0/10


Device: Flame v2.2 (Pass) 
Build ID               20150721162504
Gaia Revision          e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gaia Date              2015-07-15 21:05:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a73051740290
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150721.203051
Firmware Date          Tue Jul 21 20:31:03 EDT 2015
Bootloader             L1TC000118D0

Device: Flame master (Pass)
Build ID               20150721160205
Gaia Revision          84c3bf622e211046d905803b34de5d331761f22d
Gaia Date              2015-07-21 16:28:35
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1875a5584e5f
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150721.194129
Firmware Date          Tue Jul 21 19:41:42 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.