[Flame][Camera]The recording time and Red point overlaps in Camera.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Camera
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Paladin, Assigned: pdahiya)

Tracking

({regression})

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8564694 [details]
logcat_flame_1721.txt

[1.Description]:
[Flame][v2.2][Camera]The recording time and Red point overlaps while we record a video in landscape mode with Camera.
Attachment:  logcat_flame_1721.txt and overlap.3gp
Occurrence time: 17:21

[2.Testing Steps]: 
1. Open Camera.
2. Switch  to Video Mode.
3. Switch device to landscape mode.
4. Tap Record button.

[3.Expected Result]: 
4. The recording time and Red point do not overlap.

[4.Actual Result]: 
4. The recording time and Red point overlaps in top right corner.

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150214002504
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/6de30e6bbc84
Gecko Version          37.0a2

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8564695 [details]
overlap.3gp
(Reporter)

Comment 2

3 years ago
I can reproduce this issue on Flame 3.0 
Reproducing rate: 5/5

Device Info:
Build ID               20150214010227
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a7c177546ca0
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150214.043959
Firmware Date          Sat Feb 14 04:40:10 EST 2015
Bootloader             L1TC000118D0
status-b2g-master: --- → affected

Comment 3

3 years ago
Need UI enhancement.

Comment 4

3 years ago
Hi, Paladin,

Can it be reproduced on v2.1?
Thanks.
Flags: needinfo?(jihao)
(Reporter)

Comment 5

3 years ago
Hi William,
I can't reproduce this issue on latest Flame 2.1
Reproducing rate: 0/5

Device Info:
Build ID               20150215001204
Gaia Revision          e8eba437af02820f74d122aec83b6001df6f89e3
Gaia Date              2015-02-13 05:26:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/9d04f9149ca4
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.040742
Firmware Date          Sun Feb 15 04:07:53 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(jihao) → needinfo?(whsu)
(Reporter)

Updated

3 years ago
status-b2g-v2.1: --- → unaffected

Comment 6

3 years ago
Thanks Paladin.
It is a regression.
Flags: needinfo?(whsu)
Keywords: regression
Set 2.2? for regression
blocking-b2g: --- → 2.2?
QA Whiteboard: [COM=Gaia::Camera]

Comment 8

3 years ago
Blocking Reason: Recording time is overlapped with "Red Record" cue leading to poor experience

Its hopefully a very quick fix on the display. 

Punam can you take this one?

Thanks
Hema
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(pdahiya)
(Assignee)

Updated

3 years ago
Assignee: nobody → pdahiya
Flags: needinfo?(pdahiya)
(Assignee)

Comment 9

3 years ago
Taking bug to investigate and submit fix.
(Assignee)

Comment 10

3 years ago
On debugging, this issue appears to be fallout of RTL fix in bug 1104110.

When phone is rotated 90 and 180 deg, red icon and recording time overlaps. Removing left:auto and right:2rem for deg90 and deg180 fixes this issue in 2.2 and master

https://github.com/mozilla-b2g/gaia/blob/master/apps/camera/style/recording-timer.css#L97
Created attachment 8569373 [details] [review]
[gaia] punamdahiya:Bug1133304 > mozilla-b2g:master
(Assignee)

Comment 12

3 years ago
Comment on attachment 8569373 [details] [review]
[gaia] punamdahiya:Bug1133304 > mozilla-b2g:master

Hi Wilson
Please review attached PR that fixes
a) red icon and recording time overlaps when phone is rotated 90 and 180 deg
b) Recording timer shift seen when phone is rotated 90 and 270 deg in RTL mode.
Thanks!
Attachment #8569373 - Flags: review?(wilsonpage)
Attachment #8569373 - Flags: review?(wilsonpage) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

3 years ago
Comment on attachment 8569373 [details] [review]
[gaia] punamdahiya:Bug1133304 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):Bug 1104110
[User impact] if declined: When phone is rotated 90 and 180 degree, while recording red icon and recording time overlaps.

In RTL mode, recording timer position is shifted in landscape mode.
 
[Testing completed]: On master
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]:None
Attachment #8569373 - Flags: approval-gaia-v2.2?(bbajaj)

Updated

3 years ago
Attachment #8569373 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/1edca464539ac319c91bbb1ac743dc14db2565d7
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
Target Milestone: --- → 2.2 S7 (6mar)
This issue is verified fixed for the latest Nightly 3.0 and 2.2 builds.

Actual Results:  The red dot and record time do not overlap when rotated.
	
Environmental Variables:
Device: Flame 3.0 KK (Full Flash) (319 MB)
BuildID: 20150303010233
Gaia: c8ed1085a67490a1ecd7f275e5de9487e1b93b1d
Gecko: 0b3c520002ad
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (Full Flash) (319 MB)
BuildID: 20150303002527
Gaia: 3d188c414e30acc392253d5389a42352fcfbc183
Gecko: c89aad487aa5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [COM=Gaia::Camera] → [COM=Gaia::Camera][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.