command line argument "-remote 'openURL(url)'" does not work

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: dzu, Unassigned)

Tracking

38 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150215030238

Steps to reproduce:

Call "firefox -remote 'openURL(http://www.heise.de)'"



Actual results:

A new window witht the start page opens.


Expected results:

A new tab showing the requested URL in the runnnig firefox should open.

Note that this happens in firefox nightly 38.0a1 (2015-02-15) but still works as expected in
35.0.1.
Reporter

Comment 1

4 years ago
In the meantime I tried to debug this in todays nightly some more.

It turns out that the commandline correctly gets sent through 'client.SendCommandLine'
from the called firefox.  The running firefox process also correctly receives the parameters and nsXRemoteService::HandleCommandLine() gets executed. It seems 'cmdline' is built correctly, but I could not make sense what happens in cmdline->Run().  After execution of this method, the new
window showing the home page pops up and HandleCommandLine returns "200 executed command".

Unfortunately currently I don't understand what should happen in cmdline->Run() and why it does not work any more....

Comment 2

4 years ago
They removed -remote in bug 1080319.
Blocks: 1080319
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
Reporter

Comment 3

4 years ago
Hi Aleksej, thanks for pointing out the removal - I wasn't aware of this.

However I still wonder why no error message like "unrecognized option '-remote'" is output.
Doing some checks it seems that all unknown options are just silently ignored.  This certainly
contradicts my expectations but certainly is out of scope for this report :(

Comment 4

4 years ago
(In reply to dzu from comment #3)
> However I still wonder why no error message like "unrecognized option
> '-remote'" is output.
> Doing some checks it seems that all unknown options are just silently
> ignored.  This certainly
> contradicts my expectations but certainly is out of scope for this report :(

You can file an enhancement bug asking for that.  Make it block the removal one.
Mistakenly filed against Firefox 38 and should be instead 38 Branch. Sorry for the spam. dkl
Version: Firefox 38 → 38 Branch
You need to log in before you can comment on or make changes to this bug.