[Homescreen] Under certain circumstances in edit mode, the homescreen will scroll while the user is moving an icon

VERIFIED DUPLICATE of bug 1118006

Status

defect
VERIFIED DUPLICATE of bug 1118006
4 years ago
4 years ago

People

(Reporter: tchevalier, Assigned: cwiiis)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

Posted file Video of the issue
STR:
Enter in Edit mode
2. Long press an icon and move it elsewhere.
3. Quickly start long tapping on another icon (you have to start long tapping before the first icon has finished moving to its new spot)

Actual result:
As you can see on the attached video , if you move the icon on the screen, the homescreen is scrolling at the same time, so the icon actually stays at the same spot (you can only move it horizontally).

Expected result:
The homescreen doesn't scroll and behave as usual

Might be a dupe, but since it's pretty difficult to describe, couldn't find any related bugs.

Tested on Flame with current master + v18D
Adding the link here as well, easier to just click on it. https://www.youtube.com/watch?v=Xh7gau-9CNg
This is possibly an APZ issue, or something that we are doing to trigger some weirdness in the platform. Need to dig into this a bit further.

Adding qawanted to see if we can get a branch check, and occurrence rate.
Keywords: qawanted
I can repro this bug on Flame v2.2,but can't repro this bug on Flame v2.0&2.1&3.0.

See attachments: verify_v2.2.MP4 and logcat_0525.txt
Reproduce rate: 5/10

Repro STR:
1.Long tap a icon and drag it up or down on Homescreen.
2.Quickly start long tap another icon as soon as the first icon has finished moving to its new spot.
3.Then try to move the icon.
**The homescreen is scrolling at the same time, so the icon actually stays at the same spot.  --KO
**After several move,you can move it to elsewhere.

Flame 2.0 build:
Build ID               20150216000225
Gaia Revision          ecb1bbc3b9c00f82df172427f65d6f67e34ed533
Gaia Date              2015-02-11 20:40:33
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/3051696eafcc
Gecko Version          32.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.033354
Firmware Date          Mon Feb 16 03:34:05 EST 2015
Bootloader             L1TC000118D0

Flame 2.1 build:
Build ID               20150216001203
Gaia Revision          e8eba437af02820f74d122aec83b6001df6f89e3
Gaia Date              2015-02-13 05:26:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/9d04f9149ca4
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.035307
Firmware Date          Mon Feb 16 03:53:18 EST 2015
Bootloader             L1TC000118D0

FLame 2.2 build:
Build ID               20150216002503
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/62c80c92b39e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.040540
Firmware Date          Mon Feb 16 04:05:52 EST 2015
Bootloader             L1TC000118D0

FLame 3.0 build:
Build ID               20150216010344
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e0cb32a0b1aa
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.050451
Firmware Date          Mon Feb 16 05:05:02 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [MGSEI-Triage+]
Whiteboard: [systemsfe]
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → 2.2+
Assignee

Comment 6

4 years ago
A note, my patch in bug 1118006 fixes this - I'll try to get that bug done this week, but if not I'll handle this separately.
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
See Also: → 1118006
Assignee

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1118006
verified
*2.2
Build ID               20150326164141
Gaia Revision          6d0174e28576f2f93e696a43d1ac3b03340117f6
Gaia Date              2015-03-26 21:47:33
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/820c2f2e817a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150326.201153
Firmware Date          Thu Mar 26 20:12:05 EDT 2015
Bootloader             L1TC000118D0

*master
Build ID               20150326160206
Gaia Revision          525c341254e08f07f90da57a4d1cd5971a3cc668
Gaia Date              2015-03-26 16:34:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/59554288b4eb
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150326.193247
Firmware Date          Thu Mar 26 19:32:58 EDT 2015
Bootloader             L1TC100118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.