Closed Bug 1133417 Opened 9 years ago Closed 9 years ago

Failed tests in section W4 after enabling pointer events

Categories

(Firefox :: Untriaged, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 41
Tracking Status
firefox41 --- fixed

People

(Reporter: alessarik, Assigned: alessarik)

References

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141105223254

Steps to reproduce:

Tests on TRY servers. Section W 4


Actual results:

TEST-UNEXPECTED-PASS | /pointerevents/pointerevent_constructor.html | PointerEvent constructor - expected FAIL
TEST-UNEXPECTED-OK | /pointerevents/pointerevent_constructor.html | expected TIMEOUT
TEST-UNEXPECTED-PASS | /pointerevents/pointerevent_touch-action-illegal.html | 'pan-x none' is corrected properly - expected FAIL
TEST-UNEXPECTED-PASS | /pointerevents/pointerevent_touch-action-illegal.html | 'pan-y none' is corrected properly - expected FAIL
TEST-UNEXPECTED-PASS | /pointerevents/pointerevent_touch-action-illegal.html | 'auto none' is corrected properly - expected FAIL
TEST-UNEXPECTED-PASS | /pointerevents/pointerevent_touch-action-verification.html | 'auto' is set properly - expected FAIL
TEST-UNEXPECTED-PASS | /pointerevents/pointerevent_touch-action-verification.html | 'pan-x' is corrected properly - expected FAIL
TEST-UNEXPECTED-PASS | /pointerevents/pointerevent_touch-action-verification.html | 'pan-y' is set properly - expected FAIL
TEST-UNEXPECTED-PASS | /pointerevents/pointerevent_touch-action-verification.html | 'none' is set properly - expected FAIL
TEST-UNEXPECTED-PASS | /pointerevents/pointerevent_touch-action-verification.html | 'manipulation' is set properly - expected FAIL


Expected results:

Section W4 should be green without issues.
Blocks: 960316
OS: Windows 8 → All
Hardware: x86_64 → All
To resolve this issue we should change expectation of "web-platform-test" suite.
That expectations are situated in .\testing\web-platform\meta\pointerevents folder.
Depends on: 1166347
Attached patch w4_section_tests_ver1.diff (obsolete) — Splinter Review
- Removed expected "FAIL" results.

Suggestions and comments and objections are very welcome.
Attachment #8610518 - Flags: review?(bugs)
Comment on attachment 8610518 [details] [diff] [review]
w4_section_tests_ver1.diff

r+ (looks like wpt are run only on desktop)
Attachment #8610518 - Flags: review?(bugs) → review+
If there are no objections, I will put checkin-needed flag...
...at the same time as bug 1166347 will be checkined too.
Summary: Failed tests in section W4 → Failed tests in section W4 after enabling pointer events
Assignee: nobody → alessarik
So why are these failing? The `prefs: [dom.w3c_pointer_events.enabled:true]` line should make sure that the default pref change shouldn't affect them. Should we add layout.css.touch_action.enabled there?
Flags: needinfo?(alessarik)
(In reply to :Ms2ger from comment #6)
> So why are these failing? The `prefs: [dom.w3c_pointer_events.enabled:true]`
> line should make sure that the default pref change shouldn't affect them.
> Should we add layout.css.touch_action.enabled there?
I am not quite sure for that, but I can make some test for that.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
+ Changed preference dependencies

Suggestions and comments and objections are very welcome.
Attachment #8610518 - Attachment is obsolete: true
Flags: needinfo?(alessarik)
Attachment #8612854 - Flags: review?(bugs)
Attachment #8612854 - Flags: feedback?(Ms2ger)
Comment on attachment 8612854 [details] [diff] [review]
w4_section_tests_ver2.diff

Review of attachment 8612854 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #8612854 - Flags: feedback?(Ms2ger) → feedback+
Attachment #8612854 - Flags: review?(bugs) → review+
If there are no objections, I put checkin-needed flag.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e4e4fc58ded1
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
No longer depends on: 1171022
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: