[RTL][Dialer] Vertical scrollbar appears shortly at left side of prompt text.

RESOLVED WORKSFORME

Status

defect
P3
normal
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: huayu.li, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [planned-sprint c=1])

Attachments

(1 attachment)

[1.Description]:
[RTL][Dialer] While we call out in airplane mode or without SIM card, there is a prompt view, but a vertical scrollbar appear shortly.
[2.Testing Steps]: 
Precondition:Change your device to Arabic language and enable airplane mode.
1.Launch call.
2.Call out a number.
3.Check the prompt view.

[3.Expected Result]: 
3.The scrollbar should not appear.

[4.Actual Result]: 
3.You can see there is a vertical scrollbar appears shortly.

[5.Reproduction build]: 
FLame2.2 build:
Build ID               20150216002503
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/62c80c92b39e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.040540
Firmware Date          Mon Feb 16 04:05:52 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
occasionally Recurrence,3/3

[7.TCID]: 
15424
FLame 3.0 :
Build ID               20150216010344
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e0cb32a0b1aa
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.050451
Firmware Date          Mon Feb 16 05:05:02 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [dialer-rtl]
QA Whiteboard: [dialer-rtl] → [rtl-impact]
Priority: -- → P3
See Also: → 1133137
I cannot reproduce it on flame 3.0 (20150218010226) nor on flame 2.2 (20150217162505) with base image V188.
Flags: needinfo?(huayu.li)
I DO reproduce with new base image V18D-1 \o/ same gaia same gecko
so :
- V188 working
- V18D-1 NOT working
Whiteboard: [planned-sprint c=?]
Target Milestone: --- → 2.2 S7 (6mar)
Assignee: nobody → drs.bugzilla
Whiteboard: [planned-sprint c=?] → [planned-sprint c=1]
Flags: needinfo?(huayu.li)
Summary: [RTL][Dialer] Vertical scrollbar appears shortly at left side of prompt text. → [Nexus 5][RTL][Dialer] Vertical scrollbar appears shortly at left side of prompt text.
Summary: [Nexus 5][RTL][Dialer] Vertical scrollbar appears shortly at left side of prompt text. → [RTL][Dialer] Vertical scrollbar appears shortly at left side of prompt text.
Target Milestone: 2.2 S7 (6mar) → 2.2 S8 (20mar)
Assignee: drs.bugzilla → nobody
Target Milestone: 2.2 S8 (20mar) → ---
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15424/
Flags: in-moztrap+
Whiteboard: [planned-sprint c=1] → [planned-sprint c=1], MGSEI-RTL-3F
Please see bug 1133137 comment 15 - I'm pretty sure this bug have the same root cause.
QA Whiteboard: [rtl-impact] → [rtl-impact][MGSEI-Triage+]
QA Whiteboard: [rtl-impact][MGSEI-Triage+] → [rtl-impact][MGSEI-Triage+]MGSEI-RTL-3F
Whiteboard: [planned-sprint c=1], MGSEI-RTL-3F → [planned-sprint c=1]
This issue cannot be reproduced on latest build of FlameKK2.2, FlameKKv2.5,AriesKKv2.5.
Rate:5/5
Device: FlameKK 2.2
Build ID               20150811032503
Gaia Revision          102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gaia Date              2015-08-06 20:46:56
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/13c447ed929e
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150811.065030
Firmware Date          Tue Aug 11 06:50:39 EDT 2015
Bootloader             L1TC000118D0

Device: Flame kk 2.5
Build ID               20150811150203
Gaia Revision          2d7f369fd923b6df3b00d76844c413c1202c04ba
Gaia Date              2015-08-11 09:58:44
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/38c1ea9ccae31700630f1fe0d651e94c0c5b9e1d
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150811.182056
Firmware Date          Tue Aug 11 18:21:06 EDT 2015
Bootloader             L1TC000118D0

Device: AriesKK_2.5
Build ID               20150810201912
Gaia Revision          fa89e03dc489e79baa0e74cb1d205260c7924caa
Gaia Date              2015-08-10 10:07:57
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3f135a8ead22
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150810.194258
Firmware Date          Mon Aug 10 19:43:05 UTC 2015
Bootloader             s1
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.