failing to target profile with -remote when opened with -no-remote. as -new-instance is not giving us new instance

RESOLVED DUPLICATE of bug 1138053

Status

()

defect
RESOLVED DUPLICATE of bug 1138053
4 years ago
4 years ago

People

(Reporter: noitidart, Unassigned)

Tracking

36 Branch
x86_64
Windows 8.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150212154903

Steps to reproduce:

Per here: https://bugzilla.mozilla.org/show_bug.cgi?id=716110#c37

I'm using Windows, I have not tested on other platoforms.

I click the firefox icon, this launches my default firefox profile.

Then I go to run and run firefox.exe -P Dev -no-remote

This launches my second profile.

Then I do firefox.exe -P Dev -remote -new-tab "about:blank"

but it doesnt seem to work :(


Actual results:

Nothing happens


Expected results:

Tab should be opened in the targeted profile.
Reporter

Updated

4 years ago
Blocks: 716110
Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter

Comment 1

4 years ago
Oh my goodness, the -remote was removed in FF36? I cant find the bug for it, but the docs say so: https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options#-remote_remote_command

Is there an alternative?
Reporter

Comment 2

4 years ago
Btw that explains why it didnt work, ive been using FF36 (im on beta channel) wow so odd why remove it O_O i need it heavily for my addon profilist: https://addons.mozilla.org/en-US/firefox/addon/profilist/
Thanks for reporting this. We are still discussing it in bug 1080319.
Reporter

Comment 4

4 years ago
Thanks Liz your comment got me looped into that bug.
Reporter

Updated

4 years ago
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1138053
You need to log in before you can comment on or make changes to this bug.