Closed Bug 1133935 Opened 7 years ago Closed 7 years ago

"ASSERTION: FinishReflowChild with unconstrained container width!"

Categories

(Core :: Layout, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, regression, testcase)

Attachments

(2 files)

Attached file testcase
###!!! ASSERTION: FinishReflowChild with unconstrained container width!: 'aContainerWidth != NS_UNCONSTRAINEDSIZE', file layout/generic/nsContainerFrame.cpp, line 961

This assertion is part of code added in https://hg.mozilla.org/mozilla-central/rev/c16d59bb79d1
Now it also triggers:

###!!! ASSERTION: ReflowChild with unconstrained container width!: 'aContainerWidth != NS_UNCONSTRAINEDSIZE', file layout/generic/nsContainerFrame.cpp
Attached file stacks
(In reply to Jesse Ruderman from comment #1)
> Now it also triggers:
> 
> ###!!! ASSERTION: ReflowChild with unconstrained container width!:
> 'aContainerWidth != NS_UNCONSTRAINEDSIZE', file
> layout/generic/nsContainerFrame.cpp

That's not really a change in behavior; it's just because we fixed the wording of the assertion in ReflowChild, which used to incorrectly refer to FinishReflowChild. (We're asserting in both methods, but previously they shared identical wording.)
WFM
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.