unnecessary big memcpy in nsZipArchive::InflateItem

VERIFIED DUPLICATE of bug 189528

Status

()

VERIFIED DUPLICATE of bug 189528
17 years ago
10 years ago

People

(Reporter: dveditz, Assigned: dveditz)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
nsZipArchive::InflateItem does an extra memcpy of every file's content when it's
inflating into a buffer instead of a file (the usual case). It could use the
allocated buffer directly in the inflate step.

Comment 1

17 years ago
It would be good to measure the improvement if this is a lot of time sink. Gut
feel is this could save about 215 memcpy of <filesize> and all files we read on
startup arent that big (< 4k). Let me know if you want me to help measure the cost.

If it is an easy thing to fix, go ahead.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 2

16 years ago
This 'bug' has been solved not so long ago, and should be closed.
See bug 189528.

*** This bug has been marked as a duplicate of 189528 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
yup.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Miscellany → General
QA Contact: brendan → general
You need to log in before you can comment on or make changes to this bug.