Clicking "Abrir" (Open) won't launch a purchased paid app, but it works for a free app

RESOLVED WORKSFORME

Status

Marketplace
Payments/Refunds
P1
normal
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: vedolin, Assigned: ngoke)

Tracking

2015-03-17
x86
Gonk (Firefox OS)
Points:
---

Details

(Whiteboard: [qa+])

Attachments

(7 attachments)

(Reporter)

Description

3 years ago
Created attachment 8566104 [details]
Clicking Abrir (Open) will not launch a purchased paid app. Works for free apps.log

Connectivity:Wi-Fi
SIM used:(Telcel) 556 506-2733
Gaia/device: 2.0/Flame 
test app used:onlyboku75; CNN Mexico


steps to reproduce:

1 - Purchase a paid application (onlyboku75 was used).
2 - On the "Instalar Test App" screen, click "Instalar" for installing the app
3 - Observe that the app details page now show the green "Abrir" (open) button
4 - Click on the "Abrir" button
5 - Observe that the app is not launched
6 - On the native interface, click on the purchased app
7 - Observe that the app is correctly launched
8 - Purchase a free app (CNN Mexico was used)
9 - On the "Instalar CNN Mexico" screen, click "Instalar" for installing the app
10 - Observe that the app details page now show the green "Abrir" (open) button
11 - Click on the "Abrir" button
12 - Observe that the free app is correctly launched

expected behavior:
Clicking on "Abrir" should launch the purchased paid app.

actual behavior:
Clicking on "Abrir" will not launch a purchased app.


reproducible: yes
(Reporter)

Comment 1

3 years ago
Created attachment 8566105 [details]
1_PurchasedAppShowsAbrir.png
(Reporter)

Comment 2

3 years ago
Created attachment 8566106 [details]
2_PurchasedAppShowsInstalar.png
(Reporter)

Comment 3

3 years ago
Created attachment 8566107 [details]
3_MULTIPLE_APPS_PER_ORIGIN_FORBIDDEN.png
(Reporter)

Comment 4

3 years ago
Created attachment 8566111 [details]
4_FreeAppAbrir.png
(Reporter)

Comment 5

3 years ago
Created attachment 8566113 [details]
5_FreeAppLaunchesCorrectly.png
(Reporter)

Comment 6

3 years ago
Created attachment 8566114 [details]
6_FreeAppDoesNotGetBackToInstalar.png
(Assignee)

Updated

3 years ago
Assignee: nobody → kngo

Updated

3 years ago
No longer blocks: 987661
Priority: -- → P1

Comment 7

3 years ago
Note that the button status switches from "Open" to "Install" after a few seconds.

Updated

3 years ago
Duplicate of this bug: 1134721
(Assignee)

Comment 9

3 years ago
Played with this yesterday. What I think I observed:

- Does not reproduce on -dev.
- Does not reproduce on Stage as a true packaged app.
- When it reverted to an Install button, I hacked the button to be a Launch button. Upon clicking it, it couldn't find it installed (z.apps[manifestUrl] is undefined).

Comment 10

3 years ago
I can consistently reproduce this on a 2.0 device.

1. Search for :paid
2. Start the purchase of an app
3. Sign in using FxA
4. Enter PIN
5. Complete the purchase using Boku or Bango flows.
6. Install the app you just purchased
7. Notice that the button state changes to "Open " or "Abrir"(in Spanish)
8. Click on the Open button to launch the app
9. Switch to a different app like Settings
10. Return to Marketplace and notice the button status of the app you just purchased.

observed behavior:
After step #8, app fails to launch.
After step #10, the button status has reverted back to "Install"

ashes: 6a875
(Assignee)

Comment 11

3 years ago
Does this reproduce on prod?
(Assignee)

Updated

3 years ago
Flags: needinfo?(krupa.mozbugs)
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Whiteboard: [qa+]
Target Milestone: --- → 2015-03-17

Comment 12

3 years ago
Bango purchases are failing right now. I will give this a try once that is addressed.

Updated

2 years ago
Flags: needinfo?(krupa.mozbugs)
You need to log in before you can comment on or make changes to this bug.