[RTL][Contacts] The alphabet picker is located on the left side of the contacts app

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: dharris, Assigned: autra)

Tracking

({regression})

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 attachments)

Description:
When in RTL layout, the alphabet picker is located on the left side of the screen. According to the bidi spec sheet: https://mozilla.app.box.com/s/bcm3s5i2v6js5uk0ws3tsywse8bgncgo on page 16, it says the alphabet picker should be located on the right, due to the majority of the population being right handed.

Prerequisites: Have language set to Arabic (عربي), and have at least 1 contact in the contacts app

Repro Steps:
1) Update a Flame to 20150217074222
2) Open Contacts app
3) Observe Alphabet picker (Index scroll bar) 

Actual:
Alphabet picker is mirored over to the left


Expected:
Alphabet picker, and indexed scrolling stays on the right side.

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150217074222
Gaia: ae02fbdeae77b2002cebe33c61aedeee4b9439fd
Gecko: 4bb425001d8a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 10/10
See attached: Screenshot
This issue DOES occur on Flame 2.2

Alphabet picker is mirored over to the left

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150218002515
Gaia: da509caa7395d3d090ce973e8de082b4680a590d
Gecko: 96da179a7d3a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
This is definitely a regression, it was still on the right on recent builds. Nominating as P1 but seems like I can't change the feature blocking feature flag.
Keywords: regression
Priority: -- → P1
(Assignee)

Updated

4 years ago
Assignee: nobody → augustin.trancart
(Assignee)

Updated

4 years ago
Attachment #8566594 - Flags: review?(jmcf)
Agree, this has been working in recent master during this week.
blocking-b2g: --- → 2.2?

Comment 5

4 years ago
Triage is blocking because this is a regression.
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8566594 [details] [review]
[gaia] autra:bug-1134306 > mozilla-b2g:master

LGTM
Attachment #8566594 - Flags: review?(jmcf) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

4 years ago
Comment on attachment 8566594 [details] [review]
[gaia] autra:bug-1134306 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Probably #1116803
[User impact] if declined: low impact.
[Testing completed]: on flame v2.2
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Attachment #8566594 - Flags: approval-gaia-v2.2?
Attachment #8566594 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Depends on: 1135927
No longer depends on: 1135927
This issue is verified fixed on Flame Master and 2.2.

Result: The alphabet picker is located on the right side in RTL mode.
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150224010314
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 368c62292249
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150224002637
Gaia: 8e98fe665f3821d10d4d982cbb14cbe5b94d0be5
Gecko: 2b70d9d62799
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
=============================================

However, this fix seems to have caused bug 1135927. The checkboxes when the user tries to delete contacts overlap with the alphabet picker.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)

Comment 11

4 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15383/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.