Intermittent browser_bug592641.js | uncaught exception - Error: operation not possible on dead CPOW at :0

RESOLVED FIXED in Firefox 49

Status

()

Firefox
General
P5
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: RyanVM, Assigned: kevin, Mentored)

Tracking

(Blocks: 1 bug, {intermittent-failure})

unspecified
Firefox 51
intermittent-failure
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(e10s+, firefox47 wontfix, firefox48 wontfix, firefox49 fixed, firefox50 fixed, firefox51 fixed)

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Reporter)

Description

3 years ago
The dead CPOW error doesn't look good.

09:21:13 INFO - 66 INFO TEST-START | dom/html/test/browser_bug592641.js
09:21:15 INFO - JavaScript error: , line 0: Error: operation not possible on dead CPOW
09:21:15 INFO - 67 INFO checking window state
09:21:15 INFO - 68 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
09:21:15 INFO - 69 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "resource:///modules/sessionstore/TabState.jsm" line: 96}]
09:21:15 INFO - 70 INFO TEST-PASS | dom/html/test/browser_bug592641.js | Title should be correct on load #1
09:21:15 INFO - 71 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "chrome://mochitests/content/browser/dom/html/test/browser_bug592641.js" line: 33}]
09:21:15 INFO - 72 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "chrome://mochitests/content/browser/dom/html/test/browser_bug592641.js" line: 33}]
09:21:15 INFO - 73 INFO TEST-UNEXPECTED-FAIL | dom/html/test/browser_bug592641.js | uncaught exception - uncaught exception: undefined at :0
09:21:15 INFO - Stack trace:
09:21:15 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:simpletestOnerror:1476
09:21:15 INFO - null:null:0
09:21:15 INFO - JavaScript error: , line 0: uncaught exception: undefined
09:21:15 INFO - 74 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "chrome://mochitests/content/browser/dom/html/test/browser_bug592641.js" line: 52}]
09:21:15 INFO - 75 INFO Console message: [JavaScript Error: "uncaught exception: undefined"]
09:21:15 INFO - 76 INFO Console message: [JavaScript Error: "Error: operation not possible on dead CPOW"]
09:21:54 INFO - 77 INFO Console message: 1424280114489 Toolkit.GMP WARN GMPInstallManager.parseResponseXML got node name: html, expected: updates
09:21:54 INFO - 78 INFO Console message: [JavaScript Error: "1424280114491 Toolkit.GMP ERROR GMPInstallManager.simpleCheckAndInstall Could not check for addons: {"target":{},"message":"got node name: html, expected: updates"}" {file: "resource://gre/modules/Log.jsm" line: 749}]
09:21:54 INFO - 79 INFO Console message: 1424280114711 Services.HealthReport.HealthReporter WARN Saved state file does not exist.
09:22:43 INFO - Xlib: extension "RANDR" missing on display ":0".
09:22:44 INFO - TEST-INFO | screentopng: exit 0
09:22:44 INFO - 80 INFO TEST-UNEXPECTED-FAIL | dom/html/test/browser_bug592641.js | Test timed out - expected PASS
09:22:44 INFO - 81 INFO MEMORY STAT vsize after test: 21991423696896
09:22:44 INFO - 82 INFO MEMORY STAT residentFast after test: 494071808
09:22:44 INFO - 83 INFO TEST-OK | dom/html/test/browser_bug592641.js | took 90129ms
09:22:44 INFO - 84 INFO TEST-UNEXPECTED-FAIL | dom/html/test/browser_bug592641.js | Found a tab after previous test timed out: http://mochi.test:8888/browser/dom/html/test/bug592641_img.jpg - expected PASS
09:22:44 INFO - 85 INFO TEST-UNEXPECTED-FAIL | dom/html/test/browser_bug592641.js | Found a tab after previous test timed out: http://mochi.test:8888/browser/dom/html/test/bug592641_img.jpg - expected PASS
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 17

3 years ago
Not really sure as to the best component for this, but Core::IPC probably isn't.
tracking-e10s: --- → ?
Component: IPC → General
Product: Core → Firefox

Updated

3 years ago
Blocks: 984139
tracking-e10s: ? → +
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Summary: Intermittent browser_bug592641.js | uncaught exception - uncaught exception: undefined at :0 → Intermittent browser_bug592641.js | uncaught exception - Error: operation not possible on dead CPOW at :0

Comment 57

2 years ago
7 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 5
* mozilla-inbound: 1
* mozilla-aurora: 1

Platform breakdown:
* osx-10-6: 5
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-02-29&endday=2016-03-06&tree=all

Comment 58

2 years ago
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 4
* fx-team: 1

Platform breakdown:
* linux64: 4
* linux32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-04-04&endday=2016-04-10&tree=all

Comment 59

2 years ago
13 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 7
* fx-team: 5
* try: 1

Platform breakdown:
* linux64: 11
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-04-11&endday=2016-04-17&tree=all

Comment 60

2 years ago
16 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 12
* try: 1
* mozilla-central: 1
* fx-team: 1
* ash: 1

Platform breakdown:
* linux32: 10
* linux64: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-04-18&endday=2016-04-24&tree=all

Comment 61

2 years ago
12 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-central: 4
* mozilla-inbound: 3
* fx-team: 3
* try: 1
* mozilla-aurora: 1

Platform breakdown:
* linux64: 6
* linux32: 5
* windows7-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-04-25&endday=2016-05-01&tree=all

Comment 62

2 years ago
16 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 7
* fx-team: 5
* mozilla-central: 2
* try: 1
* mozilla-aurora: 1

Platform breakdown:
* linux64: 12
* linux32: 4

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-05-10&endday=2016-05-16&tree=all

Comment 63

2 years ago
30 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 19
* fx-team: 6
* mozilla-central: 3
* try: 1
* ash: 1

Platform breakdown:
* linux64: 19
* linux32: 11

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-05-16&endday=2016-05-22&tree=all

Comment 64

2 years ago
26 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 14
* fx-team: 11
* mozilla-central: 1

Platform breakdown:
* linux64: 21
* linux32: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-05-23&endday=2016-05-29&tree=all

Comment 65

2 years ago
20 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 13
* fx-team: 4
* mozilla-central: 2
* mozilla-aurora: 1

Platform breakdown:
* linux64: 14
* linux32: 6

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-05-30&endday=2016-06-05&tree=all

Comment 66

2 years ago
29 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 21
* fx-team: 4
* mozilla-central: 2
* try: 1
* mozilla-aurora: 1

Platform breakdown:
* linux64: 19
* linux32: 9
* windows7-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-06-06&endday=2016-06-12&tree=all

Comment 67

2 years ago
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 2
* fx-team: 2
* try: 1

Platform breakdown:
* linux64: 3
* linux32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-06-13&endday=2016-06-19&tree=all

Comment 68

2 years ago
26 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 17
* mozilla-central: 3
* mozilla-aurora: 3
* fx-team: 2
* autoland: 1

Platform breakdown:
* linux64: 18
* linux32: 6
* windows7-32: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-06-20&endday=2016-06-26&tree=all

Comment 69

2 years ago
29 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 13
* fx-team: 9
* mozilla-beta: 2
* mozilla-aurora: 2
* autoland: 2
* mozilla-central: 1

Platform breakdown:
* linux64: 18
* linux32: 10
* windows7-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-06-27&endday=2016-07-03&tree=all
Intermittent e10s test failure
Priority: -- → P5

Comment 71

2 years ago
40 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 13
* autoland: 12
* fx-team: 6
* try: 3
* mozilla-beta: 3
* mozilla-central: 2
* mozilla-aurora: 1

Platform breakdown:
* linux64: 20
* linux32: 14
* windows7-32: 4
* windows8-64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-07-04&endday=2016-07-10&tree=all

Comment 72

2 years ago
25 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 8
* mozilla-inbound: 7
* fx-team: 3
* mozilla-central: 2
* mozilla-aurora: 2
* try: 1
* mozilla-beta: 1
* ash: 1

Platform breakdown:
* linux64: 12
* linux32: 8
* windows7-32: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-07-11&endday=2016-07-17&tree=all

Comment 73

2 years ago
15 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 5
* mozilla-inbound: 4
* mozilla-aurora: 2
* fx-team: 2
* try: 1
* ash: 1

Platform breakdown:
* linux64: 15

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-07-18&endday=2016-07-24&tree=all
(Reporter)

Updated

2 years ago
status-firefox47: --- → wontfix
status-firefox48: --- → wontfix
status-firefox49: --- → affected
status-firefox50: --- → affected

Comment 74

2 years ago
20 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 9
* autoland: 4
* fx-team: 3
* mozilla-central: 2
* try: 1
* ash: 1

Platform breakdown:
* linux64: 11
* linux32: 8
* osx-10-10: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-07-25&endday=2016-07-31&tree=all

Comment 75

2 years ago
24 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 13
* fx-team: 5
* autoland: 3
* try: 1
* mozilla-central: 1
* mozilla-beta: 1

Platform breakdown:
* linux64: 16
* linux32: 6
* osx-10-10: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-08-01&endday=2016-08-07&tree=all

Comment 76

2 years ago
17 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 6
* autoland: 5
* mozilla-central: 2
* fx-team: 2
* mozilla-beta: 1
* mozilla-aurora: 1

Platform breakdown:
* linux64: 12
* linux32: 5

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-08-08&endday=2016-08-14&tree=all

Comment 77

2 years ago
31 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 12
* autoland: 11
* fx-team: 5
* mozilla-aurora: 2
* mozilla-beta: 1

Platform breakdown:
* linux64: 16
* linux32: 11
* osx-10-10: 4

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-08-15&endday=2016-08-21&tree=all
Hey kevin!

So the good news is that we get stack information for dead CPOW exceptions, which really helps to narrow down where the problem is. (This is true as of about ~20 days ago since bug 1249698 landed).

Clicking on the "brasstacks" link from one of the OrangeFactor comments, I was able to find the test log, which has this in it:

01:45:14     INFO -  255 INFO TEST-UNEXPECTED-FAIL | dom/html/test/browser_bug592641.js | uncaught exception - Error: operation not possible on dead CPOW at load2Done@chrome://mochitests/content/browser/dom/html/test/browser_bug592641.js:52:7
01:45:14     INFO -  testScope/test_executeSoon/<.run@chrome://mochikit/content/browser-test.js:993:9
01:45:14     INFO -  Stack trace:
01:45:14     INFO -  chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:simpletestOnerror:1609
01:45:14     INFO -  JavaScript error: chrome://mochitests/content/browser/dom/html/test/browser_bug592641.js, line 52: Error: operation not possible on dead CPOW
01:45:14     INFO -  256 INFO Console message: [JavaScript Error: "Error: operation not possible on dead CPOW" {file: "chrome://mochitests/content/browser/dom/html/test/browser_bug592641.js" line: 52}]
01:45:14     INFO -  load2Done@chrome://mochitests/content/browser/dom/html/test/browser_bug592641.js:52:7
01:45:14     INFO -  testScope/test_executeSoon/<.run@chrome://mochikit/content/browser-test.js:993:9

So the problem appears to be in dom/html/test/browser_bug592641.js on line 52:

http://searchfox.org/mozilla-central/rev/f80822840bc5f3d2d3cae3ece621ddbce72e7f54/dom/html/test/browser_bug592641.js#52

And what we've got here is a test attempting to access the title of a loaded page by way of the contentWindow CPOW. It should instead ask the tab2Browser object directly, via

ctx.tab2Browser.contentTitle

Can you make that change and make sure the test passes? If so, we can push this one to try. After that, if you're starting to get the hang of it, maybe you can go on a spree and start taking care of some of the rest of the (many) dead CPOW exceptions[1]: I know our tree sheriffs would be pretty happy about that!

[1]: https://bugzilla.mozilla.org/buglist.cgi?quicksearch=dead%20CPOW&list_id=13186804
Assignee: nobody → kevchan85
Mentor: mconley
(Reporter)

Comment 79

2 years ago
(In reply to Mike Conley (:mconley) - (Needinfo me!) from comment #78)
> And what we've got here is a test attempting to access the title of a loaded
> page by way of the contentWindow CPOW. It should instead ask the tab2Browser
> object directly, via
> 
> ctx.tab2Browser.contentTitle

Can't help but wonder if this pattern is frequent enough that a mass find & replace would be in order. And yes, ++ to fixing dead CPOW failures!
Not too many hits:

https://dxr.mozilla.org/mozilla-central/search?q=contentWindow.document.title&=mozilla-central

But this did point out that there's a _2nd_ usage within this file that should probably be updated as well.
(Assignee)

Comment 81

2 years ago
Created attachment 8785358 [details] [diff] [review]
bug1134307_Dead_CPOW.diff

I finished this one. I have the other line in another file.
Attachment #8785358 - Flags: review?(mconley)
(Assignee)

Comment 82

2 years ago
Mike, I have the other bug ready to upload Should I create a new bug and post it there? I cannot find anything referencing this file from a quick search beside this thread.
Flags: needinfo?(mconley)
(Assignee)

Comment 83

2 years ago
Created attachment 8785375 [details] [diff] [review]
bug1134307_Dead_CPOW_tab_1_and_2.diff

This patch has changes to lines referencing contentTitle for tabs 1 and two.
Attachment #8785375 - Flags: review?(mconley)
(Assignee)

Comment 84

2 years ago
Created attachment 8785376 [details] [diff] [review]
bug1134307_Dead_CPOW_1.diff

This file has a change to line 33
I think fixing both of these CPOW uses in browser_bug592641.js in this bug makes sense. However, I think we can probably safely have the changes occur in the same file. Can you please combine your patches?
Flags: needinfo?(mconley) → needinfo?(kevchan85)
(Assignee)

Comment 86

2 years ago
Created attachment 8785381 [details] [diff] [review]
bug1134307_Dead_CPOW.diff

Here the file with both patches. I will start looking at other CPOW stuff as you suggested.
Attachment #8785358 - Attachment is obsolete: true
Attachment #8785358 - Flags: review?(mconley)
Attachment #8785375 - Attachment is obsolete: true
Attachment #8785375 - Flags: review?(mconley)
(Assignee)

Comment 87

2 years ago
Thank you for removing the other patches I was trying to figure out how to do it on this thread.
(Assignee)

Comment 88

2 years ago
Created attachment 8785384 [details] [diff] [review]
bug1134307_Dead_CPOW.diff
Attachment #8785376 - Attachment is obsolete: true
Attachment #8785381 - Attachment is obsolete: true
Attachment #8785384 - Flags: review?(mconley)
Comment on attachment 8785384 [details] [diff] [review]
bug1134307_Dead_CPOW.diff

Review of attachment 8785384 [details] [diff] [review]:
-----------------------------------------------------------------

This looks great to me! I'm going to push this to try.

In the meantime, take a look at the list of bugs and feel free to needinfo? me on any that you want. I'll assign you and help you where you need.

Thanks for your work!
Attachment #8785384 - Flags: review?(mconley) → review+
(Assignee)

Comment 91

2 years ago
Mike what are the flags for? I was watching the testing it says its done. Is there anything else I can do?
Hrm, not sure why the more recent push wasn't put in the bug. The one in comment 90 was obsolete (I forgot to request retriggers).

So here's the right one: https://treeherder.mozilla.org/#/jobs?repo=try&revision=cc09e297fff69d67caa4853909b9aa91bfc09d73

What I've done is pushed a request to our automation to run all of the tests under dom/html/test (including the one you've fixed). I've requested 20 retriggers each to see if the intermittent failure shows up in any of them.

Each of our test "types" is represented by a symbol in that link, and there's even further categorization after that. For example, "1" and "bc1" are part of the M suite. In this case, M stands for mochitest, which is the name of the testing framework that we're using. 1 and bc1 are flavours of mochitest, and each flavour has different capabilities and powers. Your test is a "browser" mochitest, so it's running in the ones that start with "bc".

Checking the test log of one of the Linux 64 bc1s here: https://archive.mozilla.org/pub/firefox/try-builds/mconley@mozilla.com-cc09e297fff69d67caa4853909b9aa91bfc09d73/try-linux64/try_ubuntu64_vm_test-mochitest-browser-chrome-1-bm51-tests1-linux64-build473.txt.gz

If I do a Find in Page on that log, I can find browser_bug592641.js, so the test you patched is running in that suite, and it appears to be passing.

Green means pass. Orange means one or more tests failed. In this case, I'm seeing failures on OS X 10.10 debug for "1" (Also called "Mochitest 1"). Clicking on that orange will show a readout of the failure in the bottom pane. Each one is reporting this failure:

TEST-UNEXPECTED-FAIL | leakcheck | default process: 10216 bytes leaked (BasicContainerLayer, BasicImplData, BasicLayerManager, BasicPaintedLayer, CompositableClient, ...)

Which is a pre-existing very frequent orange, and is almost certainly unrelated to your patch, so we can ignore it. The red "1" in the M-e10s group means that the test resulted in the browser crashing, but this one says that this is an intermittent assertion failure for the dom/html/test/test_fullscreen-api.html test, so again, unrelated.

So so far, we're looking okay here. The intermittents that we just saw in the try push are annoying because they're not related, but we have to check on them anyway to see if we've broken anything. That's precisely why your work here is so useful - the more intermittents we get rid of, the more we can trust our test results the first time! :)

I've left the needinfo on myself to check the try build once all of the tests are done (likely on the weekend or on Monday), after which, if we're all green, we should be good to land.

In the meantime, let me know if you want any suggestions on another bug like this you can fix.
Flags: needinfo?(kevchan85)
This looks good to me on try, despite the other (unrelated) oranges.
Flags: needinfo?(mconley)
Author: kevin <kevchan85@yahoo.com>
Bug number: 1134307
Commit message: Bug 1134307 - Remove a CPOW from browser_bug592641.js to avoid a dead CPOW intermittent. r=mconley
Keywords: checkin-needed
OS: Linux → Unspecified
Hardware: x86_64 → Unspecified

Comment 95

2 years ago
36 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 18
* fx-team: 7
* mozilla-inbound: 6
* try: 2
* mozilla-central: 2
* mozilla-aurora: 1

Platform breakdown:
* linux64: 24
* linux32: 10
* windows7-32-vm: 1
* osx-10-10: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-08-22&endday=2016-08-28&tree=all
(Reporter)

Comment 96

2 years ago
I tweaked the commit message to be a bit more descriptive.

Comment 97

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/89ea6ea53888
Access the title of the loaded page by using ctx.tab2Browser.contentTitle in browser_bug592641.js to avoid CPOW usage. r=mconley
Keywords: checkin-needed

Comment 98

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/89ea6ea53888
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
(Reporter)

Comment 99

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/da952731c13a
status-firefox50: affected → fixed
Flags: in-testsuite+
(Reporter)

Comment 100

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/009ea36672be
status-firefox49: affected → fixed

Comment 101

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cea23a652dcf
Remove some CPOWs from browser_windowName.js to avoid a dead CPOW intermittent. r=mconley

Comment 102

2 years ago
11 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 4
* mozilla-beta: 2
* try: 1
* mozilla-inbound: 1
* mozilla-central: 1
* mozilla-aurora: 1
* ash: 1

Platform breakdown:
* linux64: 7
* linux32: 3
* windowsxp: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1134307&startday=2016-08-29&endday=2016-09-04&tree=all
You need to log in before you can comment on or make changes to this bug.