hotelplease.com - Javascript problem

RESOLVED WORKSFORME

Status

P4
major
RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: jquereda, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
There's a problem browsing this URL:

http://www.hotelplease.com

I think there's a problem running javascript.

Comment 1

17 years ago
Must be a layer issue by seeing the included JavaScript files and 95% sure it
should be moved to Tech Evangelism.

Comment 2

17 years ago
Right, it's an Evangelism issue. In the JavaScript Console, we see:

Error: document.all has no properties
Source File: http://www.hotelplease.com/include_js/standard.js
Line: 51


This occurs as follows. From http://www.hotelplease.com/main.html,
here is the browser detection for Netscape: 

<script language="Javascript">

  var n = document.layers ? 1:0;


Then, in http://www.hotelplease.com/include_js/standard.js, we have
many functions like this:


function VOLCAR(div,text)
{
 if (n)
 {
  var lyr = document.layers[div].document
  lyr.open()
  lyr.write(text)
  lyr.close()
 }
 else document.all[div].innerHTML = text  <<<<<<<<<<<<<<<<<<<<<< Line 51
}


Since |n| evaluates to false in Mozilla, (layers are no longer supported),
we fall into the IE codepath, which errors since document.all is IE-only.


Reassigning to Tech Evangelism -
Assignee: rogerl → nitot
Status: UNCONFIRMED → NEW
Component: Javascript Engine → Europe: West
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: pschwartau → caillon
Version: other → unspecified

Comment 3

17 years ago
Confirming. Setting P4
Priority: -- → P4
(Reporter)

Comment 4

17 years ago
This website has been redesigned, and with its actual design it works properly 
with Mozilla 0.9.7
Setting Resolution to WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 5

17 years ago
Should be marked fixed for tracking purposes.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 6

17 years ago
Fixed
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
And verified fixed with 2002021821 builds
Status: RESOLVED → VERIFIED
New Component. Page only displays blue background, reopening.
Status: VERIFIED → REOPENED
Component: Europe: West → English Other
Resolution: FIXED → ---

Comment 9

15 years ago
en other default owner
Assignee: nitot → english-other
Status: REOPENED → NEW
QA Contact: z-caillon-obsolete2 → english-other

Comment 10

15 years ago
This seems to have been fixed again / the site has changed its code making the
bug invalid. Marking WFM : Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.8a) Gecko/20040416 Firefox/0.8.0+

Status: NEW → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.