internal url for private window start page shown in task/window switcher

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: aryx, Assigned: kgrandon)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

B2G 3.0 20150218010226 on Flame (v188 base image)

The window switcher shows the internal url for the private window.

Steps to reproduce:
1. Open browser.
2. Tap on the button 'Private Window'.
3. Long tap the Home button.

Actual result:
Url "system.gaiamobile.org/private_..." shown under title "Private Window"

Expected result:
No url shown.
blocking-b2g: --- → 2.2?
Whiteboard: [systemsfe]
(Assignee)

Updated

4 years ago
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
Comment on attachment 8567553 [details] [review]
[gaia] KevinGrandon:bug_1134337_cards_view_app_window_title > mozilla-b2g:master

Sam - could you give me a hand with the review here? Thanks!
Attachment #8567553 - Flags: review?(sfoster)
Comment on attachment 8567553 [details] [review]
[gaia] KevinGrandon:bug_1134337_cards_view_app_window_title > mozilla-b2g:master

LGTM
Attachment #8567553 - Flags: review?(sfoster) → review+
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

4 years ago
Comment on attachment 8567553 [details] [review]
[gaia] KevinGrandon:bug_1134337_cards_view_app_window_title > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Feature implementation.
[User impact] if declined: Poor ux in task manager and private browser.
[Testing completed]: Manual and unit testing.
[Risk to taking this patch] (and alternatives if risky): Low risk, small patch and contained within the task manager.
[String changes made]: None.
Attachment #8567553 - Flags: approval-gaia-v2.2?(bbajaj)
blocking-b2g: 2.2? → 2.2+
Attachment #8567553 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Verified fixed with B2G 2.2 20150225002505 on Flame (v188 base image).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.