[search] [non English UI] Link to Settings to disable searchsuggestions from notification/warning on first use of rocketbar doesn't work/open window

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: aryx, Assigned: apastor)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

B2G 3.0 20150218010226 on Flame (v188 base image)

The link to the Settings app to disable search suggestions from the notification shown on first use of the rocketbar doesn't open the Settings window.

Steps to reproduce:
1. Factory reset phone.
2. Assure that a Wi-Fi or data connection is available.
3. Type something into rocketbar on the home screen.
Actual & expected result:
Notification about search suggestions shown.
4. Tap on the blue text 'Settings' in the notification.
Actual result:
Nothing happens.
Expected result:
Search settings opened. There is code for this: https://github.com/mozilla-b2g/gaia/blob/17bea27216a9377f6c77ae123fc9b403bdb7a181/apps/search/js/search.js#L176
Can QA reproduce?
Keywords: qawanted
Whiteboard: [systemsfe]
blocking-b2g: --- → 2.2?
QA Contact: ychung
I was unable to reproduce this bug on the original build on both base image v188 and v18D-1. 

Result: Selecting "Settings" brings a settings screen.

V188
Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150218010226
Gaia: 82f286f10a41aab84a0796c89fbefe67b179994b
Gecko: 9696d1c4b3ba
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro rate: 0/10
(3 out of 10 times, the main settings page opens instead of the Search screen.)

V18D-1
Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150218010226
Gaia: 82f286f10a41aab84a0796c89fbefe67b179994b
Gecko: 9696d1c4b3ba
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro rate: 0/7
-----------------------------------------------------

leaving qawanted for others to try.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Could only reproduce the expected behavior once with latest nightly, and that with the English UI. The tap on the settings link didn't work with French or German UI (tried a half dozen times).

The text gets set as innerHTML, so maybe the event listener for the click gets attached to the English UI after loading which gets replaced later. needinfoing Zibi for more insight into this.
Flags: needinfo?(gandalf)
Summary: [search] Link to Settings to disable searchsuggestions from notification/warning on first use of rocketbar doesn't work/open window → [search] [non English UI] Link to Settings to disable searchsuggestions from notification/warning on first use of rocketbar doesn't work/open window
blocking-b2g: 2.2? → 2.2+
I was able to reproduce this on Flame 3.0 and Flame 2.2

If the user is using another language besides English, begins typing in a search in the rocketbar and then taps on "settings" when prompted about "Search Suggestions", nothing will happen.

Environmental Variables:
Device: Flame 3.0 (Full Flash)(KK)(319mb)
BuildID: 20150223010224
Gaia: a6881205deae450757a8d1e1ed65e5e5be0ec633
Gecko: 86d2bb8bb1c9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Environmental Variables:
Device: Flame 2.2 (Full Flash)(KK)(319mb)
BuildID: 20150223002503
Gaia: 389542b71c89253c0d176d3b0bfb54e275c19bf1
Gecko: 9fd3441c8983
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

--------------------------------------------------

This issue does not occur on Flame 2.1 

There is not a "Search Settings" shortcut that the user can tap on when prompted about "Search Suggestions".

Environmental Variables:
Device: Flame 2.1 (Full Flash)(KK)(319mb)
BuildID: 20150223001204
Gaia: 88c44f2243a5ca1683587aca9faf29023974b96c
Gecko: efd5205ec813
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Assignee

Updated

4 years ago
Assignee: nobody → apastor
Assignee

Comment 5

4 years ago
I'm not getting that prompt about Search Suggestions. Is there anything special I need to do? I tried flashing last pvt mozilla-central and also doing 'make reset-gaia' from master.

Thanks!
Flags: needinfo?(ktucker)
I am seeing the Search Suggestions prompt on the latest Flame 3.0 nightly from PVT. Are you making sure to type at least three characters in the rocketbar with a data connection enabled? This prompt will only appear the first time you use rocketbar, but you are doing this from fresh flashes so you should be fine. The prompt will not show up without those two things.

Device: Flame 3.0
Build ID: 20150303010233
Gaia: c8ed1085a67490a1ecd7f275e5de9487e1b93b1d
Gecko: 0b3c520002ad
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Flags: needinfo?(ktucker)
Assignee

Comment 8

4 years ago
Comment on attachment 8572572 [details] [review]
[gaia] albertopq:1134350-search-suggestions > mozilla-b2g:master

Re-getting the html element on every prompt, as the element is in the locales files and gets replaced on every translation
Attachment #8572572 - Flags: review?(kgrandon)
Comment on attachment 8572572 [details] [review]
[gaia] albertopq:1134350-search-suggestions > mozilla-b2g:master

Would be good to have a test for this. Thanks!
Attachment #8572572 - Flags: review?(kgrandon) → review+
Assignee

Comment 10

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/27a969a28ac337c7a9c60055951a3904be8ff9cf
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Assignee

Comment 11

4 years ago
Comment on attachment 8572572 [details] [review]
[gaia] albertopq:1134350-search-suggestions > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: When changing the language on the FTU (or before doing the first search), the settings link placed in the first search suggestions prompt won't work
[Testing completed]: Added unit tests
[Risk to taking this patch] (and alternatives if risky): Simple change with tests
[String changes made]: -
Attachment #8572572 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8572572 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed in the lates Nightly Flame 3.0 and 2.2 builds.

Actual Results: Pressing the settings text in the search suggestsion bubble brought the user to the settings page in languages other than english.  Languages in LTR (French) and RTL (Arabic) were tested.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150311110236
Gaia: 2b87ee8e7e2ec30a9851b6b59a899006a98767ab
Gecko: bc6aeea72290
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150311002522
Gaia: 3f032238a52f08e4c2f68a47ad065a96eb22d470
Gecko: 004fa1cb1dd4
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: needinfo?(gandalf)
You need to log in before you can comment on or make changes to this bug.