All users were logged out of Bugzilla on October 13th, 2018

Mozilla unable to use page like Netscape 4.7x/Konqueror [Referer not set when loading page from popdown menu]

RESOLVED FIXED in mozilla1.2alpha

Status

()

RESOLVED FIXED
17 years ago
16 years ago

People

(Reporter: smooge, Assigned: rpotts)

Tracking

Trunk
mozilla1.2alpha
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
For several releases of Mozilla (at least from 0.8), I have been unable to use
the pulldown menu on the kingsfeature comics page to view previous comics. I get
the image un-available graphic which comes up if you 'request' the image
directly in the browser. Originally I thought it might be a JS problem but it
looks more to be in how the HTTP request is being done for this image. 

I have been able to reach this page in IE on Windows, Konqueror and Netscape
4.7[567] so I figured it came up as behaviour that 'should' work (even if
whatever the website is doing is broken.)

[I opened a bug report long ago on another email address (smooge@redhat.com) but
I hadnt heard anything on it before I left Red Hat in June. I tried to search
for the bug here, but came up with nothing and thought I had better 're-open'
the bug.]

Please let me know if there is anything I can do to help debug this. I have
tried to be helpful to Blizzard in the past on bugs that needed fixed.

Comment 1

17 years ago
Well, your original report was bug 78216, which was resolved dupe of 74284.

This one's been resolved fixed, but reopened in bug 83229, now fixed.

Since your problem is still occuring, I guess we have a new problem...

Comment 2

17 years ago
The menu is actually using JavaScript. Adding to my tracking bug, bug 113492.

Updated

17 years ago
Blocks: 113492

Comment 3

17 years ago
I see this too, Win98SE, 2001120504

Confirming, OS->All

I agree with the reporter, I think the Javascript is working as intended, and
it's the actual retrieval of the image that's going pear-shaped.

Try this (you may want to clear your cache if doing this repeatedly) : 
1) go to http://www.kingfeatures.com/features/comics/lagoon/about.htm
2) select a date from the drop-down.  Observe the error-image where there should
be a cartoon about marine life.
3) right click on the error image and select "view image".  Now you can see the
URL that it tried to get the cartoon from.
4) hit reload.  Cartoon Marine Life!

Freaky.  So why didn't it load the first time we asked for it?

I think we need someone who can trace the HTTP transactions and see what on
earth is going on in there.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 4

17 years ago
i just tried the 2001121008 linux build and could not reproduce this problem.

reporter, gavin: can you provide more information your network setup?  ie. how
are you connecting to the internet?  thx!
(Reporter)

Comment 5

17 years ago
Pretty standard setup as far as a I can tell.

Linux Box (RH 7.2 + Blizzards latest mozilla RPM 2001120815)
  +-----100 baseT----+
                     |
                  Masquerading Linux Box
                     |
                  Internet via Time Warner Cable.

I went into Red Hat last week and duplicated it in their network also. My test
of doing so was to go to

http://www.kingfeatures.com/features/comics/safehavn/about.htm

go to pull down menu in frame and pull down to Nov 14,2001 and let image
autoload in. Get the 'Sorry this image is not available.'. Trying the solution
that the Windows reporter listed (view image, reload) didnt work for me :(.

Comment 6

17 years ago
ok, ic the problem now.. thx!

Comment 7

17 years ago
Created attachment 61115 [details]
network trace using Netscape 4.75

Comment 8

17 years ago
Created attachment 61117 [details]
network trace using Mozilla 2001121008

Comment 9

17 years ago
notice that 4.75 is sending a referer whereas mozilla is not.  i suspect this
might be why the server decides to send mozilla an error page.

Comment 10

17 years ago
-> docshell

docshell should assign the http referrer for this just as it would if a link on
a page were clicked.
Assignee: darin → adamlock
Component: Networking: HTTP → Embedding: Docshell
QA Contact: tever → adamlock

Updated

17 years ago
Summary: Mozilla unable to use page like Netscape 4.7x/Konqueror → Mozilla unable to use page like Netscape 4.7x/Konqueror [Referer not set when loading page from popdown menu]

Comment 11

17 years ago
-> Rick

I think this may be covered by some work Rick is already doing.
Assignee: adamlock → rpotts
(Reporter)

Comment 12

17 years ago
Hi, is there anything I can do to help on this bug further? Code areas to peruse?
Thanks..

Updated

17 years ago
Keywords: 4xp
Target Milestone: --- → mozilla0.9.9

Comment 13

17 years ago
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
Target Milestone: mozilla0.9.9 → mozilla1.2

Updated

17 years ago
Blocks: 61660

Comment 14

17 years ago
Just an update:  There was a fix to referrer stuff being sent that went in early
in the 0.9.9 cycle, which doesn't appear to have made a blind bit of difference.  

So, problem still there, 2002030508, win98SE.

Comment 15

16 years ago
this wfm with mozilla 1.1 installer linux
(Assignee)

Comment 16

16 years ago
is this still a problem?  or can we close this bug out...

it seems to work for me...

-- rick
(Reporter)

Comment 17

16 years ago
I think the bug can be closed out. I just tried an old build on the system, and
found that the problem no longer occured with the pages. The pages seem to have
been redesigned after Netscape 7.0 came out, so I am guessing that if the
problem still exists, it was fixed on the server side.

[My apologies for not closing it sooner. I thought the fix had occured in the
code, and didnt check the old box.]
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.