Implement a self-hosted version of Array.prototype.sort

RESOLVED DUPLICATE of bug 715181

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 715181
3 years ago
3 years ago

People

(Reporter: ejpbruel, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
As far as I can tell, we currently don't have a self-hosted version of Array.prototype.sort.

This function is used extensively in our source map library to sort the mapping arrays after parsing. Parsing source maps is a significant performance bottleneck for us. We would like to experiment with using a self-hosted version of Array.prototype.sort to see if it would improve our performance in this area.
This is bug 715181. It's been waiting for my feedback for ages now :( The reason is, mostly, that I don't feel all that confident in my ability to actually give good feedback. If you want to dive in and do a check of the sorting itself, not the self-hosting parts, that'd be *very, very much* appreciated.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 715181
You need to log in before you can comment on or make changes to this bug.