not discarding offscreen animated gifs

RESOLVED DUPLICATE of bug 686905

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 686905
3 years ago
6 months ago

People

(Reporter: timbugzilla, Unassigned)

Tracking

Trunk
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted, URL)

(Reporter)

Description

3 years ago
On this tumblr gif blog animated gif images accumulate in memory as one scrolls down, and are not discarded when they have been scrolled past, nor when one switches tab. 

They are eventually discarded after closing the tab, but only after a significant delay (> 1 min).

Tested on current nightly win32 build in safe mode, and with D2D etc and with extensions.
(Reporter)

Comment 1

3 years ago
BTW, by the time you scroll down to the *Season 4 - Episode 17 “Night Terrors”* gif (fun episode, FWIW), this bug stops gifs from displaying at all.
Please provide the URL of this "tumblr gif blog"
Flags: needinfo?(timbugzilla)
(Reporter)

Comment 3

3 years ago
Ah ... see the "URL" field. ;-)
Flags: needinfo?(timbugzilla)
This is a long-standing problem. We have not been able to discard animated GIFs for a very long time - possibly since we introduced image discarding. It's difficult in practice (without paying a different cost like increased memory usage for each GIF) because of details of how animated GIFs are decoded and how playback works.

We're aware of the problem and we have gradually been refactoring things to make it possible to discard animated GIFs, but we're not there yet. I'd like to get this fixed "soon", but it's an incremental process we're still working through, so unfortunately soon almost certainly does not mean Firefox 38 or 39.
Component: Layout: Images → ImageLib
(Reporter)

Comment 5

3 years ago
Thanks for the reply!

Just to clarify, are animated gifs normally not discarded after switching to another tab?

Updated

2 years ago
Whiteboard: gfx-noted
(In reply to timbugzilla from comment #5)
> Thanks for the reply!
> 
> Just to clarify, are animated gifs normally not discarded after switching to
> another tab?

Yeah. They are discarded when you close the tab, though.
Depends on: 1150302
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 686905
You need to log in before you can comment on or make changes to this bug.