Closed Bug 1134714 Opened 5 years ago Closed 5 years ago

[RTL][Smart Collection] Icons not showing actual apps inside the smart collection

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.2 affected, b2g-master affected)

VERIFIED WORKSFORME
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: ychung, Unassigned)

References

Details

(Whiteboard: [systemsfe][3.0-Daily-Testing])

Attachments

(2 files)

Description:
When a smart collection is added in Arabic, the icon does not show the apps from the smart collection. Instead, it shows the icons of Wikipedia, Google, and Yahoo.

Repro Steps:
1) Update a Flame to 20150219010228
2) Set the device language in Arabic under Settings > Language.
3) Press the home button.
4) Long-press any empty area on the homescreen.
5) Select Add Smart Collections.
6) Select Shopping, and select OK.
7) Observe the smart collection icon created on the homescreen.

Actual:
The icon displays Wikipedia, Google, and Yahoo icons.

Expected:
The icon displays Walmart, Amazon, and ebay icons.

Note: 
This issue also reproduces when the user selects Around Me, Entertainment, Movies, News, and Sports.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150219010228
Gaia: 620aecfde85a8b093247837c55de2708e22be1e1
Gecko: 360b5f211180
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 5/5
See attached: screenshot, logcat
Attached image SmartCollection.png
This issue also reproduces on Flame 2.2.

Result: The icon displays Wikipedia, Google, and Yahoo icons.

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150219002504
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: 159a3907b959
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Summary: [RTL][Smart Collection] Icons not showing actuall apps inside the smart collections → [RTL][Smart Collection] Icons not showing actual apps inside the smart collection
This is an interesting issue. Hermes, can you take a look and weigh in on the severity of this issue?
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker) → needinfo?(hcheng)
Priority: -- → P3
Can we please make check that this is RTL specific or not?
I cannot reproduce it but the icon should be got from e.me. Maybe from this function (https://github.com/mozilla-b2g/gaia/blob/master/apps/collection/js/create_collection.js#L26).

Kevin, could you take a look?
Flags: needinfo?(hcheng) → needinfo?(kgrandon)
Peter, Ran - I have a feeling that this may be caused by the transition to the new appsearch endpoint.

I was wondering if this was known, or if we had testing localized smart collections. Thanks!
Flags: needinfo?(ran)
Flags: needinfo?(pdolanjski)
Flags: needinfo?(kgrandon)
This issue was reported prior to the transition which happened on February 23rd, so I don't think it's directly related.
Flags: needinfo?(pdolanjski)
Now that the transition is complete, I'd like you to test once again on a clean device installation (to avoid caching issues).
Flags: needinfo?(ran) → needinfo?(ychung)
I don't see this issue anymore on Flame Master and 2.2.

Result: The smart collection icons show 3 icons of the apps from the collection.

Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150224010314
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 368c62292249
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150224002637
Gaia: 8e98fe665f3821d10d4d982cbb14cbe5b94d0be5
Gecko: 2b70d9d62799
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: NEW → RESOLVED
Closed: 5 years ago
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ychung) → needinfo?(ktucker)
Resolution: --- → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.