Closed Bug 1134819 Opened 5 years ago Closed 4 years ago

Firefox crash in VideoToolbox@0x3f24ad

Categories

(Core :: Audio/Video: Playback, defect, critical)

36 Branch
All
macOS
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, reproducible)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-4a384728-52ec-465b-b834-e42342150219.
=============================================================

Seen while running through Mac crash stats. Reproducible crash on latest beta/Aurora/Nightly. Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:36.0) Gecko/20100101 Firefox/36.0

STR:
1. Load http://readingeggspress.com/#!/comprehension_gym
2. crash
Assignee: nobody → jyavenard
Who runs 10.6 these days !??
Works for me here... The MP4 itself is incorrectly formed, and contains out of order frames.
Is it crashing only on 10.6 or other OS X version ?

Detecting such type of videos and avoid calling VideoToolbox is likely impossible.
Interestingly, it seems that VDA bailed on it and refused to play, yet VideoToolBox simply crashes
Flags: needinfo?(mozillamarcia.knous)
I cannot reproduce the crash on my 10.10.3 machine, but the video shows as Green using Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0 while it plays fine using Chrome and Safari. I can file a separate bug to track that.
Assignee: jyavenard → nobody
(In reply to Jean-Yves Avenard [:jya] from comment #1)
> Who runs 10.6 these days !??

Apparently some, since they are crashing :) - so far I have only seen the crash on 10.6.

I updated Comment 3 to describe the behavior I see on my MPB 10.10 machine.
Flags: needinfo?(mozillamarcia.knous)
Plays ok on my 10.8.5 machine.
(In reply to Jean-Yves Avenard [:jya] from comment #1)
> Who runs 10.6 these days !??

My GF still does since she doesn't want to upgrade. She got a similar crash tonight hence me locating that bug.

Don't know what URL / page caused it.

crash id is 7fb7eaac-da6e-49e7-95fb-d5ea72150909
We could disabling hardware decoding on VT to see if that helps. That may be throwing the baby out with the bath water.
With 10.6 the default is to use VDA or VT (without HW as this is only supported from 10.9 onward)
Would setting the dormant timeout to 0 reduce the number of crashes? This would mean we do a better job of using HW decoders rather than software ones.
the crash is in VideoToolbox decoding thread. At a guess bug 1192675 is going to help the situation as we could have accessed the Video toolbox in a non thread-safe manner.

Using YUV420 will also help (in 41).

Increasing the use of HW ones may not help as VDA can't do some resolutions anyway ; with YouTube typically any videos < 360p can't be decoded in HW, VDA returns an error when attempting to create the decoder.
Component: Audio/Video → Audio/Video: Playback
This bug hasn't been seen since 38.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.