[Dialer][Key Pad] When the user ends a call with a number typed into the dial pad, it will appear as though they ended the call with then newly typed number

RESOLVED FIXED

Status

Firefox OS
Gaia::Dialer
P3
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: DerekH, Assigned: gsvelto)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-v2.5 affected, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(3 attachments)

Created attachment 8566771 [details]
Dialer End Call Logcat

Description:
If the user is in a call, and they open up the dial pad and type in a new number, then end the call, the newly typed will show in the header. This can be confusing because it seems as thought the user has a ended the call with the number that was typed in the dial pad, and nwo the number they were connected too.


Repro Steps:
1) Update a Flame to 20150218183015
2) Open Dialer App> Establish a call connection
3) Open Dial pad
4) Enter in some nubmers> End the call


Actual:
Call ends with typed numbers in the Call screen header


Expected:
Call ends, but the number of the established call is present in the header

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150218183015
Gaia: cba2f0bf49b882e0044c3cc583de8fcf83d2ffa4
Gecko: 3f228d2096e5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 10/10
See attached: Logcat, Video - http://youtu.be/uPbmo9xhyCQ
This issue DOES reproduce on Flame 2.2, 2.1, 2.0 and Base Image v18D-1

Call ends with typed numbers in the Call screen header, where the number of the phone to which the call was established with should be

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150218002515
Gaia: da509caa7395d3d090ce973e8de082b4680a590d
Gecko: 96da179a7d3a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150219001626
Gaia: a43e3cdf8783e9d87156d47b8bfff0f5f44f9e2e
Gecko: 5653f229724f
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150219000202
Gaia: ecb1bbc3b9c00f82df172427f65d6f67e34ed533
Gecko: c76040f40105
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Environmental Variables:
Device: Flame Base Image v18D-1 (319mb)(Kitkat)
Build ID: 20150106124450
Gaia: 79f6218c4f30c2739575c3ab800078c2cda135cb
Gecko: d9d4000dd43a3637345a41d716dc97fdd700d715
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(jlorenzo)
Obviously a bad bug, but we're lived with it for a couple a release. I don't see any criterion which can make it as a blocker.
Flags: needinfo?(jlorenzo)
Wesley, how can I nominate this bug for tracking-b2g?
Flags: needinfo?(whuang)
We no longer need to nominate for backlogs. 
You should be able to set tracking-b2g:backlog[1] directly.
This is to encourage all the team members to groom the bucket by using the flag more frequently.

The change was made two weeks ago in Bug 1141452.


[1] https://wiki.mozilla.org/B2G/Triage#Project_Flags
tracking-b2g: --- → backlog
Flags: needinfo?(whuang)
Duplicate of this bug: 1158080
Priority: -- → P3
This was caused by bug 1104667.
Depends on: 1104667
Keywords: regression
status-b2g-v2.5: --- → affected
Assignee: nobody → gsvelto
Status: NEW → ASSIGNED
Created attachment 8688430 [details] [review]
[gaia] gabrielesvelto:bug-1134829-fix-restore-phone-number > mozilla-b2g:master
Attachment #8688430 - Flags: review?(thills)
Comment on attachment 8688430 [details] [review]
[gaia] gabrielesvelto:bug-1134829-fix-restore-phone-number > mozilla-b2g:master

Hi Gabriele,

Sorry for the delay.

This one isn't working for me.  After I connect the call, go to the keypad, enter some numbers, then hang up, I still see those digits in the callscreen header.

Thanks,
-tamara
Attachment #8688430 - Flags: review?(thills)
Comment on attachment 8688430 [details] [review]
[gaia] gabrielesvelto:bug-1134829-fix-restore-phone-number > mozilla-b2g:master

It turns out I had forgotten to add a single line to my changes, ouch. I've pushed it on top of the existing patches and it seems to be working correctly now.
Attachment #8688430 - Flags: review?(thills)
Comment on attachment 8688430 [details] [review]
[gaia] gabrielesvelto:bug-1134829-fix-restore-phone-number > mozilla-b2g:master

Hi Gabriele,

Thanks that fixed it.  It looks good.

Thank you,
-tamara
Attachment #8688430 - Flags: review?(thills) → review+
Thanks for the additional review, merged to gaia/master 7f18d9d350f5ab3dff24f6b4525e09f4aff37e2b

https://github.com/mozilla-b2g/gaia/commit/7f18d9d350f5ab3dff24f6b4525e09f4aff37e2b
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-b2g-master: affected → fixed
Resolution: --- → FIXED
Created attachment 8701319 [details]
Verified_Flame kk master.3gp

This bug has been verified as "pass" on latest build of Flame KK master 512mb & Aries KK master by the STR in Comment 0.

Results: 
When the Call ends, the number of the established call is present rather than the entered numbers in the header. 

Attachments: Verified_Flame kk master.3gp
Reproduce rate: 0/10

Device: Aries KK master( Pass )
Build ID               20151222115209
Gaia Revision          f3cf488a97ecaec43369f3e3d8a7dda52be019f9
Gaia Date              2015-12-22 02:20:26
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ad16863d1d45bd3fd7906c76fa1ac1e12d24a133
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151222.111221
Firmware Date          Tue Dec 22 11:12:28 UTC 2015
Bootloader             s1

Device: Flame KK master 512mb( Pass )
Build ID               20151222030233
Gaia Revision          f3cf488a97ecaec43369f3e3d8a7dda52be019f9
Gaia Date              2015-12-22 02:20:26
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ad16863d1d45bd3fd7906c76fa1ac1e12d24a133
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151222.071644
Firmware Date          Tue Dec 22 07:16:57 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.