Closed Bug 1134833 Opened 5 years ago Closed 5 years ago

[RTL][Contacts] Contents on Duplicate Contacts screen are mirrored, but hit detection areas are not

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S8 (20mar)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: pcheng, Assigned: arcturus)

References

Details

(Whiteboard: [3.0-Daily-Testing p=2])

Attachments

(2 files)

Attached file logcat on Flame 3.0
Contents on 'Merge duplicates' screen are mirrored in RTL, but the hit box areas are not, which would confuse the user of proper interactions on this screen.

Prerequisite:
DUT is in RTL environment.

STR:
1) Create contact A
2) Create another contact that matches A's credentials
3) On the suggested merge contacts screen, tap the checkbox to the right of the name, and tap the left edge to the name.

Expected: Tapping on the checkbox would check/uncheck the checkbox, and tapping on the left edge of name would display details on what's causing duplicate suggestion. Hitbox area corresponds with UI.

Actual: Tapping on the checkbox displays details on duplicate suggestion, and tapping on the left edge of name checks/unchecks the checkbox. Hitbox area does not correspond with UI.

Repro rate: 10/10

Video of issue:
https://www.youtube.com/watch?v=aRr-Byffa-A

Attaching a logcat.

Device: Flame (KK, 319MB, full flash)
BuildID: 20150219010228
Gaia: 620aecfde85a8b093247837c55de2708e22be1e1
Gecko: 360b5f211180
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
This issue also occurs on Flame 2.2. Merge contacts screen's hit detection area contradicts with UI.

Device: Flame 2.2
BuildID: 20150219002504
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: 159a3907b959
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Blocks: contacts-rtl
QA Whiteboard: [rtl-impact][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [3.0-Daily-Testing]
No longer blocks: contacts-rtl
Adding the RTL Contacts Meta because I think it was removed unintentionally.

Nominating 2.2? since this could confuse and frustrate the end user.
Blocks: contacts-rtl
blocking-b2g: --- → 2.2?
QA Whiteboard: [rtl-impact][QAnalyst-Triage?] → [rtl-impact][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Triage: RTL is a committed feature on 2.2. Shipping with this bug could confuse Arabic users.
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → francisco
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing p=2]
Target Milestone: --- → 2.2 S7 (6mar)
Priority: -- → P1
Status: NEW → ASSIGNED
Attachment #8571294 - Flags: review?(sergi.mansilla)
Comment on attachment 8571294 [details] [review]
[gaia] arcturus:bug-1134833 > mozilla-b2g:master

Changing r? to Fernando, since Sergi seems to be busy
Attachment #8571294 - Flags: review?(sergi.mansilla) → review?(ferjmoreno)
Comment on attachment 8571294 [details] [review]
[gaia] arcturus:bug-1134833 > mozilla-b2g:master

LGTM
Attachment #8571294 - Flags: review?(ferjmoreno) → review+
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8571294 [details] [review]
[gaia] arcturus:bug-1134833 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
RTL
[User impact] if declined:
Bad user experience
[Testing completed]:
[Risk to taking this patch] (and alternatives if risky):
Low
[String changes made]:
None
Attachment #8571294 - Flags: approval-gaia-v2.2?
Attachment #8571294 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed in the lates Nightly Flame 3.0 and 2.2 builds.

Actual Results: The hit detection on the duplicate contacts screen in RTL languages matches the icons on the screen.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150311110236
Gaia: 2b87ee8e7e2ec30a9851b6b59a899006a98767ab
Gecko: bc6aeea72290
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150311002522
Gaia: 3f032238a52f08e4c2f68a47ad065a96eb22d470
Gecko: 004fa1cb1dd4
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [rtl-impact][QAnalyst-Triage+] → [rtl-impact][QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [rtl-impact][QAnalyst-Triage?] → [rtl-impact][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.