[RTL][Dialer] Input overflow ellipsis follows RTL formatting where app input is LTR; can't view further input

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: onelson, Assigned: autra)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], )

Attachments

(3 attachments)

Reporter

Description

4 years ago
Description:
When a user dials a number, they will observe that the input follows LTR standards as by design. However, when a user inputs too many numbers, the overflow ellipsis that shows will display on the righthand side, cutting off visibility of any further input by the user. The formatting of the ellipsis should cut off any previously done input as opposed to any future input so a user can ensure they typed the input they intended.


Repro Steps:
1) Update a Flame to 20150219010228
2) Open 'Dialer' app.
3) Begin input.
4) Type 18 numbers to fill space (may vary depending on numbers input).
5) Type additional numbers.

Actual:
Ellipsis formatting follows RTL standards with LTR input (design): cuts off visibility of right hand character input.

Expected:
Ellipsis formatting follows LTR standards with LTR input: cuts off visbility of left hand character input.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150219010228
Gaia: bdc95e87dae50f94b617a43ace105dce9679d287
Gecko: 360b5f211180
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Device: Flame 2.2
BuildID: 20150219002504
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: 159a3907b959
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Issue also occurs on 2.1 devices with differences:
Results: Dialer input is RTL, and ellipsis cuts off view from LTR (hiding future input).
Device: Flame 2.1
BuildID: 20150219001626
Gaia: a43e3cdf8783e9d87156d47b8bfff0f5f44f9e2e
Gecko: 5653f229724f
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
--------------------------------------------------

Repro frequency: 5/5
See attached: 
video
logcat
Reporter

Updated

4 years ago
Blocks: dialer-rtl
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing]
triage: nominating as P2
I have done some research and there seem to be phone numbers such as in Finland that, if you add the international code, can reach up to 20 digits (see http://en.wikipedia.org/wiki/List_of_international_call_prefixes : Finland can have up to 5-digit international access codes). So this is an issue for those cases, and not seeing what numbers you are entering is an issue. However I think this can still be a case on the rarer side, which is why I edged towards a P2, instead of a P1
Priority: -- → P2
Assignee

Updated

4 years ago
Assignee: nobody → augustin.trancart
Assignee

Updated

4 years ago
Attachment #8567122 - Flags: review?(kgrandon)
Comment on attachment 8567122 [details] [review]
[gaia] autra:bug-1134910 > mozilla-b2g:master

I think a dialer peer should review this if possible. Doug - could you take a look if you have a minute? Thanks!
Attachment #8567122 - Flags: review?(kgrandon) → review?(drs.bugzilla)
Comment on attachment 8567122 [details] [review]
[gaia] autra:bug-1134910 > mozilla-b2g:master

This is failing tests.
Attachment #8567122 - Flags: review?(drs.bugzilla) → review-
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
Assignee

Comment 5

4 years ago
Comment on attachment 8567122 [details] [review]
[gaia] autra:bug-1134910 > mozilla-b2g:master

Oh sorry for the failing test. Now corrected.

For this change, I carefully checked that it affects only numbers, but don't hesitate to tell me if I forgot something and if this change is not enough specific. Thanks!
Attachment #8567122 - Flags: review- → review?(drs.bugzilla)
Attachment #8567122 - Flags: review?(drs.bugzilla) → review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
This issue is verified fixed on latest b2g inbound build. In RTL, Dialer now follows LTR format and puts ellipsis on the left so newest numbers being inputted can be seen.

Device: Flame 3.0 Master (full flash 319MB)
BuildID: 20150224155210
Gaia: f6bfd854fe4746f21bc006eac145365e85f98808
Gecko: af1e21dc0e01
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Not adding verifyme keyword for 2.2 since there's not a decision on uplifting to 2.2.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15967/
Flags: in-moztrap+
[Blocking Requested - why for this release]: Missing uplift on an RTL issue.
blocking-b2g: --- → 2.2?
triage: major issue on RTL. 
Please ask for uplifting to 2.2
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(augustin.trancart)
Assignee

Comment 11

4 years ago
Comment on attachment 8567122 [details] [review]
[gaia] autra:bug-1134910 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): lack of rtl support
[User impact] if declined: cannot see the end of a number
[Testing completed]: on flame v2.2
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Flags: needinfo?(augustin.trancart)
Attachment #8567122 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8567122 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue has been verified successfully on latest Flame 2.2 build.
See attachment: Verify2_Flame2.2_Pass.png
Reproducing rate:0/10

Flame 2.2 build:
Build ID               20150319002500
Gaia Revision          9043c11f699c15bb6072422d1dad6518d1b5ddda
Gaia Date              2015-03-19 01:40:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0442d170bec
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.042028
Firmware Date          Thu Mar 19 04:20:38 EDT 2015
Bootloader             L1TC000118D0
You need to log in before you can comment on or make changes to this bug.