OSX PDF creation from print dialog produces PDFs with no links (all hyperlinks gone)

RESOLVED DUPLICATE of bug 772291

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 772291
3 years ago
3 years ago

People

(Reporter: steve-_-, Unassigned)

Tracking

35 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8567086 [details]
resulting pdf file with missing links.pdf

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

This could be OSX only:
OS X 10.10.2
FF 35.0.1

Reproduce:

* open any webpage which has hyperlinks e.g. https://firstlook.org/theintercept/2015/02/19/great-sim-heist/
* press cmd + p to open the native print dialogue
* in the bottom left dropdown, select "open PDF in preview (to genereate a PDF file which is then viewer via the native preview.app from OSX)


Actual results:

* result is a document in preview.app as expected, but all links are gone. They are plain normal text without any color indicating the link nor the text being a hyperlink at all at the places where links are on the website version
* also this file cannot be stored. something seems to be very broken

to retrieve an actual PDF, please select "sve as pdf" instead of "open PDF in preview.app" in the dropdown in the bottom left of the osx print dialogue


Expected results:

* pdf should have links identical to the website the document was created from

resulting pdf attached. to see that there are no links hover e.g. over the twitter handles of the authors of the article.

Comment 2

3 years ago
Encountered the same result on Fx 35.0.1, Nightly 39.0a1 2015-02-23 and Chrome (version 40.0.2214.115) too, under Mac OS X 10.9.5 - links are missing when using steps from comment 0.

Updated

3 years ago
Attachment #8567086 - Attachment mime type: application/save → application/pdf

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 772291
You need to log in before you can comment on or make changes to this bug.