All users were logged out of Bugzilla on October 13th, 2018

The "Select logs to delete" button can be used on the Call info page

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jlorenzo, Assigned: gsvelto)

Tracking

({regression})

unspecified
2.2 S8 (20mar)
x86_64
Linux
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [planned-sprint c=1])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Pre-requisites
Have a couple of logs in the call log.

STR
1. Go to call log information page

Expected results
Like in 2.1, this button shouldn't be showed

Actual results
This button is there and if you use it, you actually can't pick any log event but you can tap "Select All" and delete your entire call log!
(Reporter)

Comment 1

4 years ago
[Blocking Requested - why for this release]: Regression which can lead to unwanted data loss.

QA wanted to check 2.2 and shoot a video (either on master or 2.2). If it does repro on 2.2, please nominate this bug to a 2.2 blocker.
blocking-b2g: --- → 3.0?
status-b2g-v2.2: --- → ?
Keywords: qawanted
Created attachment 8567198 [details]
logcat on Flame 2.2

This issue occurs on Flame 2.2. Long tapping on a call log, select Call Information, and the next page shows a checkmark button to the right of phone number that does not belong there and user is able to delete all call logs underneath the page.

Video of issue:
https://www.youtube.com/watch?v=bazF40q82Ww

Also attaching a logcat.

Device: Flame 2.2 (KK, shallow flash, 319MB mem)
BuildID: 20150220073201
Gaia: 2b694a5a332495f1b9db06253690a2f5a702ed80
Gecko: 5c20fbeb5f8b
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: ? → affected
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage+]
QA Contact: pcheng
(Reporter)

Comment 3

4 years ago
[Blocking Requested - why for this release]: See comment 1 + regression from 2.1
blocking-b2g: 3.0? → 2.2?
(Reporter)

Comment 4

4 years ago
Triage: Broken functionality. The fix might not worth a regression window.
blocking-b2g: 2.2? → 2.2+
Keywords: regressionwindow-wanted
Whiteboard: [planned-sprint c=?]
Target Milestone: --- → 2.2 S7 (6mar)
Whiteboard: [planned-sprint c=?] → [planned-sprint c=1]
Assignee: nobody → gsvelto
Target Milestone: 2.2 S7 (6mar) → 2.2 S8 (20mar)
Created attachment 8577287 [details] [review]
[gaia] gabrielesvelto:bug-1135063-hide-call-log-edit-button-in-call-info-view > mozilla-b2g:master
(Assignee)

Comment 6

4 years ago
Comment on attachment 8577287 [details] [review]
[gaia] gabrielesvelto:bug-1135063-hide-call-log-edit-button-in-call-info-view > mozilla-b2g:master

Crude solution to fix the problem. Ideally we'd want to show the call information panel as a slide-in element but to do so would require a significant refactoring. In the future I'd like to take a page from the SMS app on this topic with their navigation abstraction.
Attachment #8577287 - Flags: review?(thills)
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
Comment on attachment 8577287 [details] [review]
[gaia] gabrielesvelto:bug-1135063-hide-call-log-edit-button-in-call-info-view > mozilla-b2g:master

Hi Gabriele,

Looks good.  Do we need any follow up bug for the refactor that you were mentioning or is there already a bug for this in our backlog?  I don't remember seeing one, but the enhancement that you mention sounds nice.

Thanks,

-tamara
Attachment #8577287 - Flags: review?(thills) → review+
(Assignee)

Comment 8

4 years ago
(In reply to Tamara Hills [:thills] from comment #7)
> Looks good.  Do we need any follow up bug for the refactor that you were
> mentioning or is there already a bug for this in our backlog?  I don't
> remember seeing one, but the enhancement that you mention sounds nice.

We don't have one yet but I'll file one. Thanks for the review!
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

4 years ago
Comment on attachment 8577287 [details] [review]
[gaia] gabrielesvelto:bug-1135063-hide-call-log-edit-button-in-call-info-view > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): -
[User impact] if declined: One can activate the call log deletion UI from the call info page. It's not a dramatic issue but it's a pretty ugly UI glitch.
[Testing completed]: Tested on a device
[Risk to taking this patch] (and alternatives if risky): Low risk since the changes are small, the alternative would be not to take the patch at all and live with the issue.
[String changes made]: None
Attachment #8577287 - Flags: approval-gaia-v2.2?(bbajaj)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1144057

Updated

4 years ago
Keywords: verifyme

Updated

4 years ago
Attachment #8577287 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
Per Comment 9,this bug is fixed on Flame v3.0.

And this bug has been successfully verified on latest Flame v3.0.
See attachment: verified_v3.0.png
Reproduce rate: 0/5

STR:
Pre-requisite: Have a couple of logs in the "Call log".
1. Open Phone app and go to Call log tab.
2. Long tap on a call log, select "Call Information",look at the top right corner.
**The "Select logs to delete" button doesn't show in "Call Information" screen as expected.

Flame 3.0 build(Pass):
Build ID               20150317073344
Gaia Revision          738987bd80b0ddb4ccf853855388c2627e19dcc1
Gaia Date              2015-03-17 02:27:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/008b3f65a7e0
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150317.111450
Firmware Date          Tue Mar 17 11:15:00 EDT 2015
Bootloader             L1TC000118D0
-------------------------------------------------------------------------

Leaving "verifyme" for Flame v2.2.
status-b2g-master: affected → verified
This bug has been successfully verified on latest Flame v2.2.
See attachment: verified_v2.2.png
Reproduce rate: 0/5


Flame 2.2 (Pass):
Build ID               20150322002503
Gaia Revision          44c62060581fde8de1e12e94cf55e9673b401a47
Gaia Date              2015-03-20 19:05:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e6140a32902a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150322.043216
Firmware Date          Sun Mar 22 04:32:27 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
Keywords: verifyme
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.