convert makefile rules in MailNews with props2arrays.py to use moz.build GENERATED_FILES

RESOLVED FIXED in Thunderbird 38.0

Status

MailNews Core
Build Config
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Philip Chee, Assigned: ewong)

Tracking

({regression})

Trunk
Thunderbird 38.0
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=10567&repo=comm-central

> make[5]: Entering directory `/builds/slave/tb-c-cen-lx-000000000000000000/build/objdir-tb/mailnews/intl'
> mkdir -p '.deps/'
> Unified_cpp_mailnews_intl0.o
> /usr/bin/ccache /tools/gcc-4.7.3-0moz1/bin/g++ -m32 -march=pentiumpro -o Unified_cpp_mailnews_intl0.o -c -I../../dist/stl_wrappers -I../../dist/system_wrappers -include /builds/slave/tb-c-cen-lx-000000000000000000/build/mozilla/config/gcc_hidden.h -DSTATIC_EXPORTABLE_JS_API -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -DMOZ_GLUE_IN_PROGRAM -DAB_CD=en-US -DNO_NSPR_10_SUPPORT -I/builds/slave/tb-c-cen-lx-000000000000000000/build/mailnews/intl -I. -I/builds/slave/tb-c-cen-lx-000000000000000000/build/mozilla/intl/locale -I../../dist/include -I/builds/slave/tb-c-cen-lx-000000000000000000/build/objdir-tb/dist/include/nspr -I/builds/slave/tb-c-cen-lx-000000000000000000/build/objdir-tb/dist/include/nss -fPIC -DMOZILLA_CLIENT -include ../../mozilla-config.h -MD -MP -MF .deps/Unified_cpp_mailnews_intl0.o.pp -Wall -Wempty-body -Woverloaded-virtual -Wsign-compare -Wwrite-strings -Wno-invalid-offsetof -Wcast-align -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe -DNDEBUG -DTRIMMED -g -freorder-blocks -Os -fno-omit-frame-pointer /builds/slave/tb-c-cen-lx-000000000000000000/build/objdir-tb/mailnews/intl/Unified_cpp_mailnews_intl0.cpp
> In file included from /builds/slave/tb-c-cen-lx-000000000000000000/build/objdir-tb/mailnews/intl/Unified_cpp_mailnews_intl0.cpp:2:0:
> /builds/slave/tb-c-cen-lx-000000000000000000/build/mailnews/intl/nsCharsetAlias.cpp:21:37: fatal error: charsetalias.properties.h: No such file or directory
> compilation terminated.
> make[5]: *** [Unified_cpp_mailnews_intl0.o] Error 1
> make[5]: Leaving directory `/builds/slave/tb-c-cen-lx-000000000000000000/build/objdir-tb/mailnews/intl'
(Assignee)

Comment 2

3 years ago
Created attachment 8567462 [details] [diff] [review]
Fix moz.build in mailnews/intl.

proposed patch.
Attachment #8567462 - Flags: review?(Pidgeot18)
(Assignee)

Updated

3 years ago
Attachment #8567462 - Flags: review?(Pidgeot18)
(Assignee)

Comment 3

3 years ago
Created attachment 8567468 [details] [diff] [review]
proposed patch (v2)
Attachment #8567462 - Attachment is obsolete: true
Attachment #8567468 - Flags: review?(Pidgeot18)

Updated

3 years ago
Keywords: regression

Updated

3 years ago
Duplicate of this bug: 1135358
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 14

3 years ago
Comment on attachment 8567468 [details] [diff] [review]
proposed patch (v2)

Review of attachment 8567468 [details] [diff] [review]:
-----------------------------------------------------------------

I'll steal this, just confirmed it works. Thx Edmund!
Attachment #8567468 - Flags: review?(Pidgeot18) → review+

Comment 15

3 years ago
https://hg.mozilla.org/comm-central/rev/d8219513e01f -> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 38.0

Comment 16

3 years ago
Currently experiencing build failures involving this commit - a TypeError from this line:

charsetalias = GENERATED_FILES['charsetalias.properties.h']

Commenting out that line (and the two following lines, which depend on it) appears to give a successful build, but presumably without that file.
(In reply to rosuav from comment #16)
> Currently experiencing build failures involving this commit - a TypeError
> from this line:
> 
> charsetalias = GENERATED_FILES['charsetalias.properties.h']
> 
> Commenting out that line (and the two following lines, which depend on it)
> appears to give a successful build, but presumably without that file.

You probably need to update your mozilla-central checkout as well.

Comment 18

3 years ago
Ah, thanks. It's a complicated setup and I invariably forget something. Have reverted the commenting-out, grabbed the latest mozilla-central, and started the build over. Hopefully this will work now!
You need to log in before you can comment on or make changes to this bug.