Closed Bug 1135374 Opened 7 years ago Closed 6 years ago

Checkbox not working on capitainetrain.com

Categories

(Firefox :: Untriaged, defect)

38 Branch
Other
Other
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bruno.n.pagani, Unassigned)

References

Details

User Agent: 
Build ID: 20150220030202

Steps to reproduce:

I went to capitainetrain.com, try to add passenger to my search by clicking the checkbox.

Note: this require to have an account on their, however if you don’t have one (which I expect unless a french dev travelling often by train is around) and don’t want to create one just for testing, you might contact them via guichet at capitainetrain dot com, they are very nice and willing to help.


Actual results:

Clicking is taken into account (since the color of the box borders changed while clicking), but the checkbox didn’t changed its state (remains checked or unchecked).


Expected results:

The state of the checkbox should have changed. This work properly on chromium for instance.
Also, please ask if you need any logs, test, or so, I’m not a webdev so I don’t really know what could be usefull to you, and that’s especially where getting in touch with them could be usefull (I’ve send them the ID of this bug too).
It still happens with clean fresh new profile without any addons and plugins on stable Firefox?
Does Web Console or Error Console show any warnings or errors?
Flags: needinfo?(b.pagani)
It still happens on latest nightly with clean profile, however it does work correctly on stable Firefox.

In both case, there is a little JS error (something like “no any element found”, « aucun élément trouvé » in french), but I don’t think it’s relevant since it’s present even when it works.
Flags: needinfo?(b.pagani)
This bug is caused by an interaction between `label`, `input` and `tabindex`.

Given an `input` inside a container with `tabindex` inside a `label`:

* clicking on the label area toggles the checkbox (correctly)
* clicking on the checkbox itself toggles the checkbox (correctly)
* BUT clicking on the container with `tabindex` doesn't toggle the checkbox (incorrectly)

Here is a jsbin that demonstrates the problem: http://jsbin.com/budisehuyo/3/

This issue is present in Firefox 38a2 and 39a1 (but not before; it's a regression). Should I open a separate issue, or edit the title of this one?
I opened https://bugzilla.mozilla.org/show_bug.cgi?id=1141455 to track the tabindex issue.
Depends on: 1141455
This issue should be closed, right?

1141455 has been fixed, and it does indeed fix this for me. :)

Thanks.
Mistakenly filed against Firefox 38 and should be instead 38 Branch. Sorry for the spam. dkl
Version: Firefox 38 → 38 Branch
Based on Comment 6 from the reporter, changing status to RESOLVED WORKS FOR ME.
Please reopen the bug if you encounter this issue again.
Thank you.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.