If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Impossible to activate Flash on Facebook

RESOLVED INVALID

Status

()

Core
Plug-ins
RESOLVED INVALID
3 years ago
7 months ago

People

(Reporter: peterbe, Unassigned)

Tracking

37 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [platform-rel-Facebook])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8567998 [details]
Screenshot 2015-02-23 09.05.30.png

I have Shockwave Flash 16.0.0.305 set to "Ask to Activate". 

I visit Facebook and try to watch a video. See attachment. 

Clicking that "Activate Adobe Flash" does nothing. The usual chrome pop-up you get in the upper left-hand corner (the one with "Allow" or "Allow and Remember") does not show up. 

Even right-clicking and selecting "Activate this plugin" does nothing.

Considering that we advice people to set Flash in "Ask to Activate" and that Facebook is a kinda popular I think should be high priority.

Comment 1

3 years ago
Which channel are you on?
Flags: needinfo?(peterbe)
I see this too.  I found that clicking on the date in the post to go directly to the post's standalone page allows me to activate flash on that page, but I can't do it from the timeline at all.  I'm on Dev Edition (currently 37) on OS X.
(Reporter)

Comment 3

3 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #1)
> Which channel are you on?

DevEdition. 37.0a2 (2015-02-23)
Flags: needinfo?(peterbe)
I'm seeing this in Beta 36.0
Is this a Firefox regression or a change to Facebook's video player?
I've got this issue too.

Application Basics
------------------

Name: Firefox
Version: 36.0
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Multiprocess Windows: 0/2

Updated

3 years ago
Assignee: benjamin → nobody
Component: Plugin Click-To-Activate Whitelist → Plug-ins
Product: Firefox → Core

Comment 7

3 years ago
A similar issue was reported today on mozillaZine's forum, for Flash videos on Facebook and YouTube (workaround is to reload the page):
http://forums.mozillazine.org/viewtopic.php?f=38&t=2922755 
Reload page to view Flash videos
(Reporter)

Comment 8

2 years ago
This is still a bug. Even right-clicking and selecting "Activate this plugin" does nothing. 

It's not a problem when the Flash player is in a modal window. After having clicked the modal window if you refresh you're taken to the video's permalink page. E.g. https://www.facebook.com/BreakingNewsFF/videos/vb.205440396170746/838828822831897/?type=2&theater
I cannot reproduce this on Nightly with multi-process disabled. I suspect this is related to bug 1173215, which was recently fixed.

Can anybody reproduce this on Nightly with multi-process support disabled?[1]

[1]: To disable multi-process, go to about:preferences, choose the General tab on the left, and uncheck "Enable multi-process Nightly" or "Enable multi-process Firefox Developer Edition", whichever it happens to be.
Flags: needinfo?(peterbe)
(Reporter)

Comment 10

2 years ago
Created attachment 8623187 [details]
Archive.zip

Attached are 3 screenshots. 
In Nightly with e10s OFF.

Clearly I haven't flash fully activated (see top bar). 
The video don't load and just becomes grey. But when I right-click and select "Activate this plugin" it shows the "Allow?" dialog in the upper left-hand corner. 

Lastly, I allow and then I'm able to watch the video.
Flags: needinfo?(peterbe)
(In reply to Peter Bengtsson [:peterbe] from comment #10)
> Created attachment 8623187 [details]
> Archive.zip
> 
> Attached are 3 screenshots. 
> In Nightly with e10s OFF.
> 
> Clearly I haven't flash fully activated (see top bar). 
> The video don't load and just becomes grey. But when I right-click and
> select "Activate this plugin" it shows the "Allow?" dialog in the upper
> left-hand corner. 
> 
> Lastly, I allow and then I'm able to watch the video.

Thanks peterbe - so that sounds like on Nightly this is working as expected. I'm growing pretty convinced that bug 1173215 fixed this for the single-process case.
Depends on: 1173215
Whiteboard: [platform-rel-Facebook]
platform-rel: --- → ?
platform-rel: ? → ---
FWIW, I don't think the test case/original pain point on this bug is valid anymore, it looks to me like Facebook finally went all HTML5.  I haven't run into this in a long time, and there's no notification in the bar that flash is active when playing a video anymore.
(Reporter)

Comment 13

7 months ago
Yeah, Facebook has changed too much in 2 years to make this worthwhile to try to reproduce.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.