Open Bug 1135858 Opened 5 years ago Updated 2 years ago

Label for Devtools button in main menu doesn't wrap anymore

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox36 unaffected, firefox37 unaffected, firefox38 affected, firefox39 affected)

Tracking Status
firefox36 --- unaffected
firefox37 --- unaffected
firefox38 --- affected
firefox39 --- affected

People

(Reporter: tchevalier, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached image Screenshot
In Firefox 38 (annd now 39 as well) in French, the Devtools button in the main menu is now cut off instead of wrapping in two lines, like:
Développe-
ment web

Reproduced with a fresh profile as well.
Can you find a regression window?
Flags: needinfo?(theo.chevalier11)
Component: Menus → Untriaged
Toss-up between bug 1128033 and bug 1134667 ? Xidorn / Jonathan / Nick, can you investigate which specific change broke this? :-)
Flags: needinfo?(quanxunzhen)
Flags: needinfo?(nalexander)
Flags: needinfo?(jfkthame)
Product: Firefox → Core
I'm guessing https://bugzilla.mozilla.org/show_bug.cgi?id=1128033#c5 was right.
Flags: needinfo?(jfkthame)
No way bug 1134667 can be relevant, AFAICS; there's no CSS ruby involved here.
Flags: needinfo?(quanxunzhen)
Looks like this one's on me.  I'll look at the l10n repack logs; we'll likely just back this out and accept build system lameness :(
Assignee: nobody → nalexander
Flags: needinfo?(nalexander)
OS: Linux → All
Hardware: x86_64 → All
I'm not sure I follow. The issue is that labels don't wrap, not that strings are missing or similar. 
What's the relation with l10n repacks? It seems a CSS issue.
(In reply to Francesco Lodolo [:flod] from comment #8)
> What's the relation with l10n repacks? It seems a CSS issue.

OK, I should have read the bug instead of just the comment, missed the fact that the bug was touching hyphenation resources.
This looks like the proper component. Please correct if wrong.
Component: Untriaged → XP Toolkit/Widgets: Menus
(In reply to Justin - QA from comment #10)
> This looks like the proper component. Please correct if wrong.

Done.  This is fallout from build configuration around hyphenation.
Assignee: nalexander → nobody
Component: XP Toolkit/Widgets: Menus → Build Config
Depends on: 1128033
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.