Marketshare metrics for Mobile Dashboard

RESOLVED FIXED

Status

Cloud Services
Metrics: Dashboard
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Katie Parlante, Assigned: Rebecca Weiss)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Create a json or csv file and push to S3 bucket for the Mobile dashboard.

Same drill as desktop...

Here are some docs on deploying dashboards, pushing to s3 buckets, etc: https://mana.mozilla.org/wiki/display/CLOUDSERVICES/Bespoke+Dashboards

IIRC, mobile dashboard will be implemented using this repo: https://github.com/mozilla/fennec-dashboard

So, rollup files will be pushed to: s3://net-mozaws-prod-metrics-data/fennec-dashboard/<data source>.<json|csv>

Rebecca, is the format for the rollup already defined?
Hamilton, do you need anything from Rebecca?

Edwin will work with Rebecca to get s3 credentials and figure out if cloud services should be hosting the scripts.
(Reporter)

Updated

3 years ago
Flags: needinfo?(rweiss)
Flags: needinfo?(hulmer)
(Assignee)

Comment 1

3 years ago
Hi Katie,

I only work on the market share dashboard, which will be separate from the fennec dashboard.  We should probably start a separate bug for the market share dashboards, since they are separate.
Flags: needinfo?(rweiss)
(Assignee)

Comment 2

3 years ago
Hi Hamilton,

I have weekly and monthly level .json for desktop marketshare.  These are created every week and month.  Are you okay with the following schema:

{
  "pageviews": [
    {
      "date": "2009-01-01",      
      "Firefox": 0.0046
    },
    ...
   ],
  "users": [
    {
      "date": "2009-01-01",      
      "Firefox": 0.0046
    },
    ...
  ]

Monthly and weekly look exactly the same: weekly has ~4x the rows.  We currently have two levels of tracking market share, pageview and user level, so the dashboard should have two ways of showing this data.

Updated

3 years ago
Flags: needinfo?(hulmer) → needinfo?

Comment 3

3 years ago
I chatted with hulmer offline. I'm happy to take on the task of integrating this into the dashboard.
Flags: needinfo?

Comment 4

3 years ago
I've updated the dashboard with the market share data from rweiss and committed the changes to the repo: https://metrics.mozilla.com/protected/dashboards/fennec

Katie, we'll have the updated copy ready by Monday.

For reference, the two new jsons are: {fennec_marketshare_weekly.json, fennec_marketshare_monthly.json}
(Reporter)

Updated

3 years ago
Summary: External metrics for Mobile Dashboard → Marketshare metrics for Mobile Dashboard

Comment 5

3 years ago
Morning Rebecca, 'needinfo'-ing you here too, for my sake mainly, so that I don't lose track of outstanding tasks.

As with Desktop, it would appear that the two json files aren't currently being deployed?
Flags: needinfo?(rweiss)
(Assignee)

Comment 6

3 years ago
Shoot. Looks like my script didn't push.  I'll check and update the bug.
Flags: needinfo?(rweiss)
(Reporter)

Comment 7

3 years ago
I pushed the files and see them in the data directory (though the dashboard isn't displaying them).

Comment 8

3 years ago
Thanks, Katie. I can confirm that the files are now deployed.

That dashboard will remain broken until tomorrow when Hamilton fixes a few final things.

Comment 9

3 years ago
Following Sheeri's update in #1134862, the Fennec dashboard now works and I've verified that the two marketshare charts are displaying {weekly, monthly} data. As noted in #1135882, if it's at all possible to generate jsons that are sorted on date, that would be great. Otherwise, don't worry about it.

Rebecca, if everything looks good, I think we can close this bug :)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.