More "Clear Recent History" Time range choices

RESOLVED DUPLICATE of bug 581308

Status

()

RESOLVED DUPLICATE of bug 581308
4 years ago
4 years ago

People

(Reporter: jib, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

While testing Bug 1046245, I was surprised by the limited number of choices given in the "Time range to clear" in the "Clear Recent History" dialog: Last Hour, Last Two Hours, Last Four Hours, Today, and Everything.

Questionable browsing would not seem limited to 4 hours, especially at 1am in the morning. I could see someone faced with the false choice of erasing everything or nothing in that case, leading to frustration.

I expected more time choices akin to those offered by search engines, at least: Past 24 hours, Past week, Past month.

Having seen how flexible the underlying engine is, this seems like low hanging "privacy feature" improvement fruit to me.
last month seems confusing and maybe of doubtful usefulness. I can barely figure use-cases to be willing to clear a month rather than everything. Do you really remember what you visited more than a couple weeks ago? If not, there's no big point in clearing a month and keeping everything else.

7 days seems more useful, but I'd replace "Past Week" with "Last 7 days", to avoid confusion.
Makes sense. Btw, have we considered "Last 2 days"? It would be useful especially after midnight.
That's another possible option.

I think there is some ongoing work to redesign the Clear Recent History dialog but I'm not sure who is following that effort.

Updated

4 years ago
See Also: → bug 1074244
ok this is basically a dupe of bug 581308, I'll comment there about the suggested ranges.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 581308
You need to log in before you can comment on or make changes to this bug.