Should avoid loading Google JS when DNT is enabled.

RESOLVED DUPLICATE of bug 1217896

Status

www.mozilla.org
Pages & Content
RESOLVED DUPLICATE of bug 1217896
3 years ago
2 months ago

People

(Reporter: pmac, Unassigned)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1687275] )

Following the advice of the following post:

http://gu.illau.me/posts/privacy-and-google-analytics/#comply-with-do-not-track

I believe we should do this. If possible and desired we could continue using GA on IE since MS enabled DNT by default thus removing our ability to know user intent. Though recent moves by MS (new browser) make it nearly impossible to detect all MS browsers with JS. Still, it would be at least easy to detect all versions of IE with our current method and continue to opt those users in.

Updated

3 years ago
See Also: → bug 1087011
See Also: → bug 858839
We should also avoid loading JS for Google Tag Manager (when it lands) and Optimizely in this way. All of these things are already blocked by tracking protection in Firefox, but that doesn't help users of other browsers. However, it might help a tiny bit with Firefox since this should prevent the little icon in the location bar from saying that it has blocked a tracker on www.mozilla.org.

Comment 2

3 years ago
Should we generalize this to "3rd party scripts" ?

Updated

3 years ago
Whiteboard: [kb=1687275]
Perhaps use the same logic as in https://github.com/mozilla/bedrock/pull/3024/.
I wholeheartedly agree and support this. We just switched to using DDG for research links on plugin check and, this move will just further strengthen the message that Mozilla is the most trusted company when it comes to user privacy.

Comment 5

3 years ago
See bug 1217896 for the implementation.
Dup'ing..
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1217896
You need to log in before you can comment on or make changes to this bug.