A TRANS_NOT_FOUND error is displayed when the user tries to buy an app with Bango and Boku payments accounts having its price tier supported by Boku

RESOLVED DUPLICATE of bug 1136212

Status

Marketplace
Payments/Refunds
RESOLVED DUPLICATE of bug 1136212
3 years ago
3 years ago

People

(Reporter: vedolin, Unassigned)

Tracking

x86
Gonk (Firefox OS)
Points:
---

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8568651 [details]
BangoAndBokuAppBokuPriceTier_TRANS_NOT_FOUND.log

Connectivity: Data
SIM used: telcel
Gaia/device: 1.1/Inari

Test app used: https://marketplace.allizom.org/app/test-app-bangoandboku-bokusupp/

A TRANS_NOT_FOUND error is displayed when the user tries to buy an app with Bango and Boku payments accounts having its price tier supported by Boku

Steps to reproduce:

1 - Open Marketplace app when connected via carrier network connection
2 - Find a paid app with Bango and Boku payments accounts set, but with Boku pricetier unsupported ( https://marketplace.allizom.org/app/test-app-bangoandboku-bokusupp/ ) and try to purchase it
3 - Enter valid FxA credentials
4 - Enter an already set-up PIN and continue
5 - Observe the TRANS_NOT_FOUND error message


Expected bahavior:
Bango Purchase confirmation page is displayed 

Actual behavior:
TRANS_NOT_FOUND error message is displayed

reproducible: yes
(Reporter)

Comment 1

3 years ago
Created attachment 8568652 [details]
BangoAndBokuAppBokuPriceTier_TRANS_NOT_FOUND.png
(Reporter)

Comment 2

3 years ago
Perhaps related to https://bugzilla.mozilla.org/show_bug.cgi?id=1136212?

Comment 3

3 years ago
This behavior also happens with the Flame 2.0_Telcel_WIFI and DATA
looks like a dupe of bug 1136212
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1136212
You need to log in before you can comment on or make changes to this bug.