Closed Bug 1136291 Opened 5 years ago Closed 5 years ago

new non-e10s windows have tabs shifted down

Categories

(Firefox :: General, defect)

All
macOS
defect
Not set
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 39
Iteration:
39.1 - 9 Mar
Tracking Status
firefox38 + verified
firefox39 --- verified

People

(Reporter: jaas, Assigned: markh)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image ff-screenshot.png
1. Download Nightly, run it
2. Close all windows
3. Open a non-e10s window

The window opens with tabs shifted down out of the title bar. This is a recent regression, last 24-48 hours I think.
I get this:
TypeError: sourceUI._box is null browser.js:6992:8

Sounds related to bug 1123517 part 1.
Flags: needinfo?(bmcbride)
Duplicate of this bug: 1136298
Blocks: 1123517
Skippy to the rescue!
Flags: needinfo?(bmcbride)
(If it wasn't clear, I was referring to markh, who has a working patch for this already.)
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
Flags: firefox-backlog+
Attachment #8568895 - Flags: review?(bmcbride) → review+
Iteration: --- → 39.1 - 9 Mar
Flags: qe-verify?
Flags: qe-verify? → qe-verify+
https://hg.mozilla.org/mozilla-central/rev/46be8d043c5a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 39
Comment on attachment 8568895 [details] [diff] [review]
0001-Bug-1136291-better-handle-an-unexpected-eg-the-hidde.patch

Approval Request Comment
[Feature/regressing bug #]: 1123517
[User impact if declined]: Broken browser in some situations.
[Describe test coverage new/current, TreeHerder]: All still pass
[Risks and why]: None
[String/UUID change made/needed]: None
Attachment #8568895 - Flags: approval-mozilla-aurora?
[Tracking Requested - why for this release]:

We really want this for 38.
Attachment #8568895 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Reproduced on 2015-02-24 Nightly build under Mac OS X 10.9.5.
Verified as fixed using Nightly 39.0a1 and Aurora 38.0a2 2015-03-09.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.