Play control button labels are not localized

RESOLVED FIXED in Firefox OS v2.2

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: eeejay, Assigned: eeejay)

Tracking

({access, late-l10n})

unspecified
2.2 S7 (6mar)
All
Gonk (Firefox OS)
access, late-l10n

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [b2ga11y p=1])

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
In the player view, we use ::before styling and an attribute to style the label. We also need a localized string label for accessibility.
Created attachment 8568845 [details] [review]
[gaia] eeejay:bug-1136393 > mozilla-b2g:master
(Assignee)

Updated

4 years ago
Attachment #8568845 - Flags: review?(squibblyflabbetydoo)

Comment 2

4 years ago
Comment on attachment 8568845 [details] [review]
[gaia] eeejay:bug-1136393 > mozilla-b2g:master

Looks good!
Attachment #8568845 - Flags: review?(squibblyflabbetydoo) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Keywords: checkin-needed

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

4 years ago
Comment on attachment 8568845 [details] [review]
[gaia] eeejay:bug-1136393 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Play control buttons won't be localizeable and perceivable to screen reader.
[Testing completed]: Yes. It has been on master for a while.
[Risk to taking this patch] (and alternatives if risky): Low.
[String changes made]: yes, added labels for screen reader.
Attachment #8568845 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8568845 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/c7a53d73ae7599d5ead5145df8cf795f3c5e6c98
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Keywords: late-l10n
Target Milestone: --- → 2.2 S7 (6mar)
You need to log in before you can comment on or make changes to this bug.