Remove region exclusion when searching for apps from the curation tools

VERIFIED FIXED in 2015-03-10

Status

Marketplace
Curation Tools
P2
critical
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: krupa, Assigned: mat)

Tracking

2015-03-10
Points:
---

Details

(URL)

(Reporter)

Description

3 years ago
steps to reproduce:
1. Load marketplace prod
2. Search for "じゃらん"

expected behavior:
search finds https://marketplace.firefox.com/app/jalan/

actual behavior:
search returns https://marketplace.firefox.com/search?q=%E3%81%98%E3%82%83%E3%82%89%E3%82%93

API returns https://marketplace.cdn.mozilla.net/api/v2/fireplace/search/?cache=1&lang=en-US&limit=24&q=%E3%81%98%E3%82%83%E3%82%89%E3%82%93&region=us&vary=0
(Reporter)

Updated

3 years ago
Summary: Search fails to find apps named "じゃらん" → Search fails to find app named "じゃらん"
Change your region to a region the app isn't excluded in (like Japan) and search will work.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

3 years ago
This also happens on the curation tools where the region restriction shouldn't apply.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 3

3 years ago
https://marketplace.firefox.com/api/v1/apps/search/suggest?_user=---&cache=1&filtering=0&lang=en-US&limit=5&offset=0&q=%E3%81%98%E3%82%83%E3%82%89%E3%82%93&vary=0
Currently we have both region filtering and device filtering on the search suggest API which the consumer pages use. It sounds like we want neither.

Comment 5

3 years ago
I think you're correct, Rob. We want neither region or device filtering in terms of Publishing Tool search. 

Our two new big game acquisitions from Disney (Where's My Water? and Where's My Perry?) are supposed to only be available in Germany, but they are unsearchable in the Tool as well (even if my region is set to Germany).

Updated

3 years ago
Severity: normal → critical
(Reporter)

Updated

3 years ago
Component: Search → Curation Tools
Summary: Search fails to find app named "じゃらん" → Remove region exclusion when searching for apps from the curation tools

Updated

3 years ago
Assignee: nobody → mpillard
(Assignee)

Comment 6

3 years ago
I'm going to remove region filtering. Do you want the curation tools search to filter apps to return only public or valid apps ? For reference:

Consumer Pages uses:
- device, feature profile, region, *public* apps only (apps need to have been reviewed and made public by the developer to show up)

Operator Dashboard uses:
- region, *valid* apps only (apps need to have been reviewed and not disabled/deleted by the developer to show up, but private apps that normally do not show up in search are returned)


Since our code was changed multiple times it's confusing, I want to make sure you get exactly what you need.
Flags: needinfo?(sdevaney)
(Assignee)

Updated

3 years ago
Status: REOPENED → ASSIGNED

Comment 7

3 years ago
Yes, it would be ideal if the Curation Tool only searched public apps (public in at least one region; e.g. the game "Where's My Perry?" is currently only available in Germany). 

Thanks, Mathieu!
Flags: needinfo?(sdevaney)
(Assignee)

Comment 8

3 years ago
Fixed in https://github.com/mozilla/zamboni/commit/bb2fb358b3b3fd7ea611693cbc6aeabba059d9ee
and https://github.com/mozilla/transonic/commit/dfd94cf6ce803733e1086bdfc0f38f75bc0466c2

Updated STR (ignore bug description):
- Submit an app that is excluded in most regions (and more crucially, excluded in rest of world - do keep a single region)
- Push that app to public
- Make sure that app is not visible in your region in the consumer pages, but visible in the region you kept
- Log in to the curation tools, create a new collection, search for your app : it should be visible
- Add the app to the collection, make sure it works.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago3 years ago
Priority: -- → P2
Resolution: --- → FIXED
Target Milestone: --- → 2015-03-10
(Assignee)

Comment 9

3 years ago
Bonus STR:
- Repeat STR from comment 8, but this time do not push the app to public, keep it unreviewed.
- It should *not* show up in curation tools.

Comment 10

3 years ago
Verified as fixed in FF39(Win7) in marketplace.allizom.org
An app set only for a region is displayed only for that region in consumer pages, but can be found in curation tools an added in a collection regardless of the region: http://screencast.com/t/uKi3W2nX4P8
Also the scenario from comment 9 works.
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.