WebGL 1.0.3 conformance error: conformance/textures/tex-image-and-sub-image-2d-with-video-rgb565.html

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: lukebenes, Unassigned)

Tracking

(Blocks: 1 bug)

39 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: webgl-conformance gfx-noted)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150224030228

Steps to reproduce:

Verify texImage2D and texSubImage2D code paths taking video elements (RGB/UNSIGNED_SHORT_5_6_5)

https://www.khronos.org/registry/webgl/sdk/tests/conformance/textures/tex-image-and-sub-image-2d-with-video-rgb565.html?webglVersion=1


Actual results:

ANGLE:
    failed: getError expected: NO_ERROR. Was INVALID_OPERATION : should be no errors

OpenGL:
conformance/textures/tex-image-and-sub-image-2d-with-video-rgb565.html (49 of 98 passed)

    failed: at (4, 4) expected: 0,255,0 was 0,0,0
    failed: at (4, 24) expected: 255,0,0 was 0,0,0
    failed: at (4, 4) expected: 0,255,0 was 0,0,0
    failed: at (4, 24) expected: 255,0,0 was 0,0,0
    failed: at (4, 4) expected: 0,255,0 was 0,0,0
    failed: at (4, 24) expected: 255,0,0 was 0,0,0
    failed: at (4, 4) expected: 0,255,0 was 0,0,0
    failed: at (4, 24) expected: 255,0,0 was 0,0,0
    failed: at (4, 4) expected: 0,255,0 was 0,0,0
    failed: at (4, 24) expected: 255,0,0 was 0,0,0
    failed: at (4, 4) expected: 0,255,0 was 0,0,0
    failed: at (4, 24) expected: 255,0,0 was 0,0,0
    failed: at (4, 4) expected: 255,0,0 was 0,0,0
    failed: at (4, 24) expected: 0,255,0 was 0,0,0
    failed: at (4, 4) expected: 255,0,0 was 0,0,0
    failed: at (4, 24) expected: 0,255,0 was 0,0,0
    failed: at (4, 4) expected: 255,0,0 was 0,0,0
    failed: at (4, 24) expected: 0,255,0 was 0,0,0
    failed: at (4, 4) expected: 255,0,0 was 0,0,0
    failed: at (4, 24) expected: 0,255,0 was 0,0,0
    failed: at (4, 4) expected: 255,0,0 was 0,0,0
    failed: at (4, 24) expected: 0,255,0 was 0,0,0
    failed: at (4, 4) expected: 255,0,0 was 0,0,0
    failed: at (4, 24) expected: 0,255,0 was 0,0,0
    failed: at (4, 4) expected: 0,255,0 was 0,0,0
    failed: at (4, 24) expected: 255,0,0 was 0,0,0
    failed: at (4, 4) expected: 0,255,0 was 0,0,0
    failed: at (4, 24) expected: 255,0,0 was 0,0,0
    failed: at (4, 4) expected: 0,255,0 was 0,0,0
    failed: at (4, 24) expected: 255,0,0 was 0,0,0
    failed: at (4, 4) expected: 0,255,0 was 0


Expected results:

Chrome passes all the tests. Firefox fails the test with both the ANGLE and OpenGL backends.
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
Whiteboard: webgl-conformance → webgl-conformance gfx-noted
(Reporter)

Updated

4 years ago
No longer blocks: 845345
Summary: WebGL conformance error: conformance/textures/tex-image-and-sub-image-2d-with-video-rgb565.html → WebGL 1.0.3 conformance error: conformance/textures/tex-image-and-sub-image-2d-with-video-rgb565.html

Comment 1

3 years ago
Confirmed this to fail on the following hardware:
 - SPARK, GIADA, MACBOOK_AIR_OSX, MACBOOK_AIR_WIN, MACBOOK_PRO_OSX, MACBOOK_PRO_WIN, MACMINI, MACPRO, NEXUS-4, NEXUS-5, NEXUS-10, SURFACE, WINDBOX, HASWELL, HPOMEN (All tested configurations, so looks like hardware independent)

See https://bugzilla.mozilla.org/show_bug.cgi?id=1178601 for hardware configuration details of these systems.
(Reporter)

Updated

3 years ago
Blocks: 1193526
Blocks: 1246063
No longer blocks: 1193526
(Reporter)

Comment 2

2 years ago
The d3d9 and d3d11 backend are now passing on Windows 10 with HD 4000.
50.0a1 (2016-06-23)
(Reporter)

Comment 3

2 years ago
Ubuntu 16.04 also working with HD 5000.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.