WebGL 1.0.3 conformance error: conformance/textures/texture-upload-size.html

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: lukebenes, Unassigned)

Tracking

(Blocks: 1 bug)

39 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: webgl-conformance gfx-noted)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150224030228

Steps to reproduce:

https://www.khronos.org/registry/webgl/sdk/tests/conformance/textures/texture-upload-size.html?webglVersion=1


Actual results:

conformance/textures/texture-upload-size.html (48 of 53 passed)

    failed: Texture was smaller than the expected size 4x4
    failed: getError expected: INVALID_VALUE. Was NO_ERROR : when calling texSubImage2D with the same texture upload with offset 1, 1
    failed: getError expected: INVALID_VALUE. Was NO_ERROR : when calling texSubImage2D with the same texture upload with offset 1, 1
    failed: getError expected: INVALID_VALUE. Was NO_ERROR : when calling texSubImage2D with the same texture upload with offset 1, 1
    failed: getError expected: INVALID_VALUE. Was NO_ERROR : when calling texSubImage2D with the same texture upload with offset 1, 1


Expected results:

Chrome passes all the tests. Firefox fails with both the ANGLE and OpenGL backends.
Component: Untriaged → Canvas: WebGL
Product: Firefox → Core
Whiteboard: webgl-conformance → webgl-conformance gfx-noted
(Reporter)

Updated

3 years ago
No longer blocks: 845345
Summary: WebGL conformance error: conformance/textures/texture-upload-size.html → WebGL 1.0.3 conformance error: conformance/textures/texture-upload-size.html

Comment 1

3 years ago
Reproduced this to fail (seems to be hardware independent) on the following systems:
 - SPARK, GIADA, MACBOOK_AIR_OSX, MACBOOK_AIR_WIN, MACBOOK_PRO_OSX, MACBOOK_PRO_WIN, MACMINI, MACPRO, NEXUS-4, NEXUS-10, SURFACE, WINDBOX, HASWELL, HPOMEN

See https://bugzilla.mozilla.org/show_bug.cgi?id=1178601 for hardware configuration details of these systems.

Updated

3 years ago
OS: Windows 7 → All
Hardware: x86_64 → All
(Reporter)

Updated

3 years ago
Blocks: 1193526
Blocks: 1246063
No longer blocks: 1193526
(Reporter)

Comment 2

2 years ago
Passing on Intel HD 4000 under Ubuntu 16.04 and Windows 10.
50.0a1 (2016-06-25)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.