Closed Bug 1136641 Opened 5 years ago Closed 3 months ago

Add automated test for playing various audio formats

Categories

(Testing :: Firefox UI Tests, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: mihaelav, Unassigned)

References

()

Details

Add automated test for the following Moztrap scenario:
https://moztrap.mozilla.org/manage/case/11513/

Steps:
1. Launch Firefox.
2. Navigate to http://goo.gl/le1tSu.
3. Try out all the available options: toggle the play/pause buttons, mute/unmute, seek, use the contextual menu options.
 * All the performed actions work correctly.
4. In a New Tab, open http://goo.gl/ZjMXaA and repeat step 3.
 * The audio file is played correctly. All the performed actions work accordingly.
5. In a Private Browsing Window, navigate to http://goo.gl/Rs80fK and repeat step 3 for both demos.
 * The audio demos are played correctly. All the performed actions work accordingly.
6. In a New Window, navigate to http://goo.gl/TlJfJB and use all the available options: add Audio Source, create an AudioBufferSourceNode, add Module and connect them accordingly. Make sure to connect to the green circle on the right hand sign.
 * Whatever nodes are connected, all sounds can be heard.

Note: This test is part of the manual regression suite, hence automation coverage is highly desirable.
Bug 489474 was for Mozmill and had a nearly ready patch. So have a look if necessary.
See Also: → 489474
Keep in mind that we most likely cannot land such a patch right now due to the dependency of installed codecs etc. Without PuppetAgain it would be hard to keep everything up2date.
OS: Linux → All
Hardware: x86 → All
Whiteboard: [blocked by PuppetAgain for CI]
Wait. Commented on the wrong bug. This is for audio formats. So it would be good to know which additional codecs would be necessary to be installed on our various supported platforms. If there are any.
Whiteboard: [blocked by PuppetAgain for CI]
Product: Mozilla QA → Testing

No more progress in the last 2 years, so I assume it's not really needed anymore. Also Firefox ui tests will go away soon via bug 1573410.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.