Closed Bug 1136648 Opened 9 years ago Closed 9 years ago

A new tab is opened with the results if a search is performed from a pinned about:home tab

Categories

(Firefox :: Search, defect)

37 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox36 --- unaffected
firefox37 + wontfix
firefox38 + wontfix
firefox39 + wontfix

People

(Reporter: avaida, Assigned: lviknesh)

References

Details

(Keywords: regression)

Attachments

(1 file)

Reproducible on:
Nightly 39.0a1 (2015-02-24), Aurora 38.0a1 (2015-02-24), Beta 37.0b1 (20150223185154)

Affected platforms:
Windows 7 (x64), Windows 8.1 (x86), Ubuntu 14.04 (x86), Mac OS X 10.9.5

Steps to reproduce:
1. Launch Firefox with a clean profile.
2. Open a new tab and navigate to about:home.
3. Pin the tab.
4. From the page's search field, perform a search for a random keyword - (e.g.) example

Expected result:
The search is performed without any issues and the search results are displayed in the same tab.

Actual result:
The search results are displayed in a new tab.

Notes:
- I was unable to reproduce this bug on Firefox 35.0 or Firefox 36.0 (build2).
- At a first glance, this seems to be a regression, I'll follow up with a regression range as soon as possible.
Although this is an edge case, tracking as this is a regression in 37. I'd like to see if this is difficult to fix.
Regression window:

Last good revision: b836016d82b5 (2014-12-16)
First bad revision: b7eb1ce0237d (2014-12-17)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b836016d82b5&tochange=b7eb1ce0237d

Last good revision: b28b3e2104f7
First bad revision: df8db207bf66
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b28b3e2104f7&tochange=df8db207bf66
Almost certainly a regression from bug 1038599.

We should probably just back that out for beta while working on a revised solution.
Blocks: 1038599
Might be as simple as just adding a "allowPinnedTabHostChange: true", though.
Hello vikneshwar - one of your patches caused this bug (no worries - it happens!). Are you interested in working on a fix? I'm happy to assist.
Flags: needinfo?(lviknesh)
Really sorry for the bug . Hope this patch fixes it . Thank you :)
Assignee: nobody → lviknesh
Status: NEW → ASSIGNED
Flags: needinfo?(lviknesh)
Attachment #8571075 - Flags: feedback?(gavin.sharp)
Comment on attachment 8571075 [details] [diff] [review]
pinned-host.patch

This seems like the right thing to do to maintain the previous behavior.
Attachment #8571075 - Flags: review?(dao)
Attachment #8571075 - Flags: feedback?(gavin.sharp)
Attachment #8571075 - Flags: feedback+
This bug affects Firefox 37, so we will need to uplift the fix to both the DevEdition and Beta branches. Dao, can you help vikneshwar with that?

(As mentioned earlier, backing out the patch that caused this there is also an option to consider.)
Flags: needinfo?(dao)
I don't think this should be considered a bug. What's the point of pinning about:home, if not that you want it to stick around, for the current session as well as after a restart?
Flags: needinfo?(gavin.sharp)
Flags: needinfo?(dao)
Flags: needinfo?(andrei.vaida)
Comment on attachment 8571075 [details] [diff] [review]
pinned-host.patch

> function loadURI(uri, referrer, postData, allowThirdPartyFixup) {
>   try {
>     openLinkIn(uri, "current",
>                { referrerURI: referrer,
>                  postData: postData,
>-                 allowThirdPartyFixup: allowThirdPartyFixup });
>+                 allowThirdPartyFixup: allowThirdPartyFixup, 
>+                 allowPinnedTabHostChange: true });

There's a trailing space after "allowThirdPartyFixup,". Otherwise this looks good code wise, *if* we want to restore the previous behavior, but I don't think we do.
Attachment #8571075 - Flags: review?(dao) → review-
I suppose that's a good point, this is an odd use case. Let's see what Philipp (or a delegate) thinks.
Flags: needinfo?(philipp)
Flags: needinfo?(gavin.sharp)
Flags: needinfo?(andrei.vaida)
(In reply to Dão Gottwald [:dao] from comment #9)
> I don't think this should be considered a bug. What's the point of pinning
> about:home, if not that you want it to stick around, for the current session
> as well as after a restart?

It's indeed an edge case at best and I don't see any reasonable point in pinning about:home. But then again, about:home's behavior is different from about:newtab — where searching for something displays the results in the same (pinned) tab and not in a separate one — and I think that I'd be best to have an identical behavior there as well.
Flags: firefox-backlog?
Having about:home pinned is an odd thing. In Fx36, searching from the search bar opens a new tab, while searching from the awesomebar or the search field on the page performs the search within the tab.

Was this behavior ever by design? If so, it makes sense for the on-page search field to follow the same behavior as the in-chrome search field (which currently is opening in a new tab.
Flags: needinfo?(philipp)
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: firefox-backlog?
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: