SMS are ordered by delivery time

RESOLVED DUPLICATE of bug 1037620

Status

Firefox OS
Gaia::SMS
RESOLVED DUPLICATE of bug 1037620
3 years ago
3 years ago

People

(Reporter: lana, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150223030231

Steps to reproduce:

1)Turn the Airplane mode on.
2)Send a message from an other phone.
3)After a minute or two send a message from the device in Airplane mode.
4)Turn the Airplane mode off.


Actual results:

The message sent in step 3 is shown before but it was sent after the  one from step 2, and the time of the message from step 2 is the time when it was received.


Expected results:

The message from step 2 should be displayed before the one from step 3, or at least show the time when it was sent.


The issue here is that if my phone is off for 3 days and I see a message when I turn it on, I don't know which day the person sent it. Maybe it dates back from 3 days and it's old news.
Also if I send a message to this person too fast after turning my phone one, my message is shown before the one I receive.
(Reporter)

Comment 1

3 years ago
See bug 1037620
Lana, would the proposition in bug 1037620 work for you? I think it's a good compromise :)

For your last use case, maybe we could also display a warning somewhere if we receive a message after a sent message, if the received message's sentTimestamp is earlier than the sent message's timestamp? Jenny, what do you think?
Flags: needinfo?(jelee)
(Reporter)

Comment 3

3 years ago
Yes, I like the proposition in bug 1037620, especially the part to reorder the message that was mentioned by Jenny.

The warning is a good idea I'd like to try to do it. But I don't really know how those warning panels work.
Let's wait for what Jenny (our UX designer) will say :)

Comment 5

3 years ago
Hi Julien,

I think the proposal in bug 1037620 alone address both of the issues. Messages that cannot be received during airplane mode will be "late" whether or not there's a sent message or not.  
The message sent right after airplane mode off has the correct time stamp, I don't see the need to compare it with "received message's sentTimestamp" and show warning, since we already indicated the message received is late. Hope that makes sense =) Thanks!
Flags: needinfo?(jelee)
Yep, it makes sense.

Let's dupe this bug to bug 1037620. I hope we'll find some time to fix it soon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1037620
You need to log in before you can comment on or make changes to this bug.