Closed Bug 1137089 Opened 5 years ago Closed 5 years ago

The sidebar header is white on the developer edition theme

Categories

(Firefox :: Theme, defect)

38 Branch
All
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 39
Tracking Status
firefox38 --- affected
firefox39 --- verified

People

(Reporter: avaida, Assigned: Gavin)

Details

Attachments

(2 files)

Reproducible on:
Aurora 38.0a2 (2015-02-25)

Affected platform:
Ubuntu 14.04 (x64)

Steps to reproduce:
1. Launch Firefox with a clean profile.
2. Enable Reading List by setting 'browser.readinglist.enabled' to true. Restart the browser to apply the pref change.
3. Enable the Reading List sidebar by pressing [CTRL] + [ALT] + [R].
4. Check the styling of the header displayed in the sidebar - (i.e.) the "Reading List" string

Expected result:
The styling of the header is consistent with the Developer Edition theme.

Actual result:
The header's font color is white and almost unnoticeable on the sidebar.

Notes:
- This issue is reproducible only on Linux and it's isolated to Aurora's theme.
Flags: qe-verify+
This isn't specific to the ReadingList - it's true for all sidebars (history, bookmarks, etc).
Component: Reading List → Theme
Summary: The Reading List sidebar header is white on the developer edition theme → The sidebar header is white on the developer edition theme
And isn't a regression from bug 1123517.
No longer blocks: 1123517
Attached patch patchSplinter Review
This fixes is it for me, not sure if this breaks anything else though.
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #8580879 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8580879 [details] [diff] [review]
patch

Review of attachment 8580879 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with a comment explaining why (devedition.css is nice because most of the non-obvious rules have comments about why, and this should too!)
Attachment #8580879 - Flags: review?(gijskruitbosch+bugs) → review+
QA Contact: andrei.vaida
https://hg.mozilla.org/mozilla-central/rev/b65fd368fdb1
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Verified fixed on Aurora 39.0a2 (2015-04-02), using Ubuntu 14.04 (x64), Windows 7 (x64) and Mac OS X 10.9.5.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.