inspector rev in client.py is using the wrong rev in comm-beta

RESOLVED FIXED in seamonkey2.34

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: ewong, Assigned: ewong)

Tracking

SeaMonkey 2.34 Branch
seamonkey2.34
x86_64
Windows 8.1

SeaMonkey Tracking Flags

(seamonkey2.34 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

In comm-beta, client.py has:

    27     # URL of the default hg repository to clone for DOM Inspector.
    28     'INSPECTOR_REPO': 'https://hg.mozilla.org/dom-inspector/',
    29     # The stable revision to use
    30       'INSPECTOR_REV':  'DOMI_LATEST_RELEASE',

This is not right since DOMI_LATEST_RELEASE has been updated to fix
bug 1128291.  Instead, c-b should (I believe) use  'SEA2_26_RELBRANCH'
which doesn't have that change.
Posted patch proposed patch (v1) (obsolete) — Splinter Review
Attachment #8569712 - Flags: review?(bugspam.Callek)
Comment on attachment 8569712 [details] [diff] [review]
proposed patch (v1)

[Approval Request Comment]
Regression caused by (bug #): bug 1128291
User impact if declined: bustage
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #8569712 - Flags: approval-comm-beta?
I think we will need to create a new branch. Probably from the DOMI_2_0_15 branch and based on http://hg.mozilla.org/dom-inspector/rev/6abb72a17277 as you probably need the compat vers changes.
(In reply to Ian Neal from comment #3)
> I think we will need to create a new branch. Probably from the DOMI_2_0_15
> branch and based on http://hg.mozilla.org/dom-inspector/rev/6abb72a17277 as
> you probably need the compat vers changes.

Ratty suggested we use DOMI_2_0_15_1 as the tag.  

Should I go ahead and create that tag?
Flags: needinfo?(iann_bugzilla)
Attachment #8569712 - Flags: review?(bugspam.Callek)
Attachment #8569712 - Flags: approval-comm-beta?
(In reply to Edmund Wong (:ewong) from comment #4)
> (In reply to Ian Neal from comment #3)
> > I think we will need to create a new branch. Probably from the DOMI_2_0_15
> > branch and based on http://hg.mozilla.org/dom-inspector/rev/6abb72a17277 as
> > you probably need the compat vers changes.
> 
> Ratty suggested we use DOMI_2_0_15_1 as the tag.  
> 
> Should I go ahead and create that tag?

That is fine by me, I was thinking SEA2_34_RELBRANCH but DOMI_2_0_15_1 seems okay too.
Flags: needinfo?(iann_bugzilla)
Using DOMi cset 60242bd0c895 (as tagged as DOMI_2_0_15_1)
Attachment #8569712 - Attachment is obsolete: true
Attachment #8570344 - Flags: review?(bugspam.Callek)
Attachment #8570344 - Flags: review?(bugspam.Callek) → review?(Pidgeot18)
Attachment #8570344 - Flags: review?(Pidgeot18) → review+
Comment on attachment 8570344 [details] [diff] [review]
proposed patch (v2)

[Approval Request Comment]
Regression caused by (bug #): 1128291
User impact if declined: bustage during osx64 build.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
String changes made by this patch:
Attachment #8570344 - Flags: approval-comm-beta?
Comment on attachment 8570344 [details] [diff] [review]
proposed patch (v2)

Review of attachment 8570344 [details] [diff] [review]:
-----------------------------------------------------------------

Ah, sure, this is for beta, so I should have set this a+ right away :)
Attachment #8570344 - Flags: approval-comm-beta? → approval-comm-beta+
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.34
You need to log in before you can comment on or make changes to this bug.