Closed Bug 1137217 Opened 8 years ago Closed 8 years ago

Bottom corners of font panel in reader view should be rounded

Categories

(Toolkit :: Reader Mode, defect)

38 Branch
x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1142298
mozilla38

People

(Reporter: phlsa, Unassigned, Mentored)

Details

(Whiteboard: [qx:link:spec][diamond])

Attachments

(1 file)

Attached image missing round corners
The corner radius at the bottom of the font panel in reader view should match the one of the top corners.
It looks like we need to add some bottom radius values.

Let's put the new rules below the:
  #font-type-buttons > li:first-child,
  #font-size-buttons > button:first-child,
  .segmented-button > li:first-child {
rule at https://dxr.mozilla.org/mozilla-central/source/toolkit/themes/windows/global/aboutReader.css#342 and they should look like:

  .segmented-button > li:first-child {
    border-bottom-left-radius: 4px;
  }

  .segmented-button > li:last-child {
    border-bottom-right-radius: 4px;
  }
Mentor: bwinton
Whiteboard: [qx] → [qx][diamond]
Component: Reading List → Reader Mode
Product: Firefox → Toolkit
Target Milestone: --- → mozilla38
Version: Firefox 38 → 38 Branch
I want to work on this bug.
Thanks.
Flags: needinfo?(bwinton)
Sounds good.  Do you understand how to show the Font Panel?
Flags: needinfo?(bwinton)
Hi,
Actually I dont know about how to show the front panel.
and please tell me how to reproduce the BUG.
Thanks.
Flags: needinfo?(bwinton)
Step 1: Go to about:config and make sure "reader.parse-on-load.enabled" is "true".
Step 2: Go to http://www.nytimes.com/2015/03/03/opinion/david-brooks-leaving-and-cleaving.html?_r=0 and wait for it to completely load.
Step 3: Click the icon in the urlbar that looks like a book.
Step 4: Click the "Aa" icon in the bar on the side of the page.
Flags: needinfo?(bwinton)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Unfortunately, this is a duplicate and was already fixed. Vikram, maybe Blake can suggest a different bug you can work on. Blake?
Flags: needinfo?(bwinton)
I believe Vikram and I have been chatting about a different bug, but I admit I forget which one it is.  Perhaps it was bug 995758?
Flags: needinfo?(bwinton)
Whiteboard: [qx][diamond] → [qx:link:spec][diamond]
You need to log in before you can comment on or make changes to this bug.