[Settings][Age Verification] When dismissing the age gate prompt 1 time, it will not appear again when selecting the "next" button

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: dharris, Assigned: kgrandon)

Tracking

({regression})

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe], URL)

Attachments

(2 attachments)

Posted file FxA Logcat
Description:
When accessing the firefox age verification page, if the user selects a birth year that makes them too young, an prompt will appear saying they are too young. IF the user dismisses this page by selecting "OK" and the taps the "next" button the prompt will no longer appear, and the button appears to be not functioning


Repro Steps:
1) Update a Flame to 20150226010233
2) Open Settings app> Firefox accounts
3) Enter in a new email address
4) Select a Year of Birth less than 13 years old.
5) Select Next
6) When age gate pops up select ok> Select Next


Actual:
Age gate message does not appear again, next button does not function until an agae above 13 years old is selected


Expected:
The age warning page shows up every time the next button is selected, if the birth year selected is not old enough

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150226010233
Gaia: 7894b929f1b0394f3c997f72a6482bc7813e758d
Gecko: dd6353d61993
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 10/10
See attached: Logcat, Video - http://youtu.be/XLGVhzXoHn4
This issue DOES occur on Flame 2.2

Age gate message does not appear again, next button does not function until an age above 13 years old is selected

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150226002503
Gaia: bf24aa57fa7760260ab05d1f53242c8d8ae59e83
Gecko: 363123044e61
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

================================================================================================================

This issue does NOT occur on Flame 2.1

The age warning page shows up every time the next button is selected, if the birth year selected is not old enough

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150226001720
Gaia: 5d3479fdd438412adee4452720856b6b771fe5cd
Gecko: 0390c73a827b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Functional regression disabling an age gate.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
QA Contact: jmercado
Bug 1123433 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150223075344
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: afdd235dcbd3
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150223094643
Gaia: 77381a5b9e4852240dc0ed5604cdbbd1fdf8571a
Gecko: 6be1c4476a76
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 31ac1cd7a029d5e46dd7c92537b5c973c5d9826e
Gecko: 6be1c4476a76

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 77381a5b9e4852240dc0ed5604cdbbd1fdf8571a
Gecko: afdd235dcbd3

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/31ac1cd7a029d5e46dd7c92537b5c973c5d9826e...74904acd2c352be5ee77fcf2ca5fab0e7e2cf4e9
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Kevin, can you take a look at this please? This might have been caused by the work done for bug 1123433.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(kgrandon)
(Assignee)

Comment 5

4 years ago
Yup, I will take this - I have an idea of what's going on.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Flags: needinfo?(kgrandon)
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
(Assignee)

Updated

4 years ago
Blocks: 1123433
(Assignee)

Comment 7

4 years ago
Comment on attachment 8571563 [details] [review]
[gaia] KevinGrandon:bug_1137354_fxa_errors_element_registration > mozilla-b2g:master

Fernando - would you have a minute to review this? I had thought I tested this, but I guess I missed it. Just need to add a check so we don't attempt to register the custom element twice. Thanks!
Attachment #8571563 - Flags: review?(ferjmoreno)
Regression
blocking-b2g: 2.2? → 2.2+
Component: Gaia::Settings → Gaia::System
Attachment #8571563 - Flags: review?(ferjmoreno) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

4 years ago
Comment on attachment 8571563 [details] [review]
[gaia] KevinGrandon:bug_1137354_fxa_errors_element_registration > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Caused by bug 1123433.
[User impact] if declined: Ui will become broken instead of showing an error dialog.
[Testing completed]: Manual and unit testing.
[Risk to taking this patch] (and alternatives if risky): Low risk, smallish patch.
[String changes made]: None.
Attachment #8571563 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8571563 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual results: The age gate prompt will appear as many times as the next button is pressed.

Environmental Variables:
Device: Flame 3.0 KK (Full Flash) (319 MB)
BuildID: 20150306010207
Gaia: 7a91c16bfa348be8b25e09719178efa051512988
Gecko: 0189941a3fd5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (Full Flash) (319 MB)
BuildID: 20150306002519
Gaia: eb86137e247224e86d17ed1a0a133b2a318dce3c
Gecko: a04034e239fb
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.