[Email][Search] When tapping the search box in the E-mail app, the keyboard does not appear until tapping the search bar again

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: dharris, Assigned: jrburke)

Tracking

({regression})

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(2 attachments)

Posted file Email Bug Logcat
Description:
When the user tap on the E-mail search bar they are brought to the search page for the Email app. The search bar is not in focus, and the keyboard does not pop up until the user taps on the search box a second time.

Repro Steps:
1) Update a Flame to 20150226010233
2) Open Email App> Sign into a valid email account
3) Scroll up to reveal search bar
4) Tap on search bar


Actual:
The user is brought to the search page, but the keyboard does not pop up, and the search field is not focused


Expected:
The user is brought to the search page with the search bar in focus with the keyboard active and ready to search

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150226010233
Gaia: 7894b929f1b0394f3c997f72a6482bc7813e758d
Gecko: dd6353d61993
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Repro frequency: 15/15
See attached: Logcat, Video - http://youtu.be/dv-Cfxt3Y40
This issue DOES occur on Flame 2.2

The user is brought to the search page, but the keyboard does not pop up, and the search field is not focused

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150226002503
Gaia: bf24aa57fa7760260ab05d1f53242c8d8ae59e83
Gecko: 363123044e61
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

===================================================================================================

This issue does NOT occur on Flame 2.1

The user is brought to the search page with the search bar in focus with the keyboard active and ready to search

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150226001720
Gaia: 5d3479fdd438412adee4452720856b6b771fe5cd
Gecko: 0390c73a827b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Functional regression of a core feature.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 2.2
BuildID: 20141002194234
Gaia: 1a1ab35aed2f1f540111abfeed1ccdc8603a8e08
Gecko: a04623b310b8
Version: 35.0a1 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken Environmental Variables:
Device: Flame 2.2
BuildID: 20141002200235
Gaia: 2c7158d88f8307b09b0db620ffc9337530e6f06a
Gecko: 1bda213c853d
Version: 35.0a1 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: 1a1ab35aed2f1f540111abfeed1ccdc8603a8e08
Gecko: 1bda213c853d

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 2c7158d88f8307b09b0db620ffc9337530e6f06a
Gecko: a04623b310b8

https://github.com/mozilla-b2g/gaia/compare/1a1ab35aed2f1f540111abfeed1ccdc8603a8e08...2c7158d88f8307b09b0db620ffc9337530e6f06a

Caused by bug 1073788
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
James, can you take a look at this please? Looks like this might be caused by the landing for bug 1073788
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(jrburke)
(Assignee)

Comment 6

4 years ago
Comment on attachment 8571603 [details] [review]
[gaia] jrburke:bug1137395-email-search-focus > mozilla-b2g:master

This was indeed affected by bug 1073788: The .blur() happens in _showCard, where message_list was doing the .focus() in the card's postInsert() method, but postInsert() is called before _showCard.

So the fix is to do the focus work in onCardVisible, which happens after the blurring, and is a better idea overall: it is best to not have the keyboard in play while we are finishing the display of the card.
Flags: needinfo?(jrburke)
Attachment #8571603 - Flags: review?(bugmail)
Comment on attachment 8571603 [details] [review]
[gaia] jrburke:bug1137395-email-search-focus > mozilla-b2g:master

I ♥ comments
Attachment #8571603 - Flags: review?(bugmail) → review+
Blocking for regression.
blocking-b2g: 2.2? → 2.2+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

4 years ago
Comment on attachment 8571603 [details] [review]
[gaia] jrburke:bug1137395-email-search-focus > mozilla-b2g:master

[Approval Request Comment]

[Bug caused by] (feature/regressing bug #):
Bug 1073788, see comment 6 above for more detail.

[User impact] if declined:
User will have to tap again in the search field to start the search.

[Testing completed]:
Tested manually on flame device.

[Risk to taking this patch] (and alternatives if risky):
Very low risk. Just moves the focus part to a card callback that happens after the card is shown.

[String changes made]:
none
Attachment #8571603 - Flags: approval-gaia-v2.2?
Attachment #8571603 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed for the latest Nightly 3.0 and 2.2 builds.

Actual Results:  The keyboard is brought up correctly when selecting the search bar.  
	
Environmental Variables:
Device: Flame 3.0 KK (319 MB) (Full Flash)
BuildID: 20150304010324
Gaia: 3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gecko: c5b90c003be8
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (319 MB) (Full Flash)
BuildID: 20150304002529
Gaia: 8b4b3e4b7e7c308764f71542437fd60625ac6b75
Gecko: 2cb52b7cda5a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.