Firefox 36 onScroll event when uses scroll function freezes

RESOLVED INVALID

Status

()

RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: zeniateo, Unassigned)

Tracking

36 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150222232811

Steps to reproduce:

Create a table which overflows and add an onScroll event. 

http://jsfiddle.net/fNPvf/12672/


Actual results:

If in onScroll event I call function which name is "scroll" and has 3 parametrs the scroll does not happen when dragging scrollbar.

http://jsfiddle.net/fNPvf/12672/


Expected results:

Scrolling should be happening.
(Reporter)

Updated

4 years ago
Severity: normal → critical
(Reporter)

Updated

4 years ago
Severity: critical → blocker

Comment 1

4 years ago
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0


I'm surprised this hasn't gotten any attention. In your example, the onscroll event handler seems to be preventing it from scrolling at all. With a similar example:
http://jsfiddle.net/cx88q0wn/3/

.. I'm able to scroll, but the event handler just will not trigger.

I would imagine this is likely the same bug.
(Reporter)

Comment 2

4 years ago
Thank you very much for your reply! In your example you use scroll function without parameters, if you add 3 parameters, it will not be able to scroll:

http://jsfiddle.net/cx88q0wn/4/

Comment 3

4 years ago
Hello,

Yes, I see this also happens when there are 2 params.

It actually seems to have to do with naming your function 'scroll'. For instance the following fixes the issue with your example: http://jsfiddle.net/fNPvf/13277/
(Reporter)

Comment 4

4 years ago
Hello,

Yes renaming helps. Of course I can sacrifice a day of mine and change all my grids to use renamed js function, BUT our company has thousands business clients. Scroll function is used in our project for at least 10 years, so even old clients now has this issue. We can not afford to upgrade ALL our clients. So I really really hope that Mozilla will some how fix this. Neither Chrome nor IE has this issue.
Mozilla/5.0 (Windows NT 6.3; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20151217030207

I can confirm that scrolling is not possible on the latest Nightly when using the test case from the Description.
Severity: blocker → normal
Status: UNCONFIRMED → NEW
Component: Untriaged → DOM: Events
Ever confirmed: true

Comment 6

3 years ago
So by calling scroll() in the onscroll event handler you call scroll method on the element.
That scroll() takes 2 params, x and y. So the testcase in comment 0 scrolls always to (1, 2).

As far as I see, all is working per specifications and also other (at least Chrome) browser have the same behavior.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID

Comment 7

3 years ago
The scroll() method on Element is defined here
https://drafts.csswg.org/cssom-view/#dom-element-scroll
You need to log in before you can comment on or make changes to this bug.