Error in both test_settings_change_language tests: exception "Element '%s' could not be foundin select wrapper"

RESOLVED FIXED

Status

defect
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: onelson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(4 attachments, 1 obsolete attachment)

Reporter

Description

4 years ago
Description:
The change language tests within the settings suite (test_settings_change_language.py and test_settings_change_language_rtl.py) are both failing in today's smoketest on Jenkins. The test opens the language changer within the Settings app before breaking; the exception indicates that the test may be passing a bad parameter for locating the language which aborts the test.

Traceback (most recent call last):
  File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1/.env/local/lib/python2.7/site-packages/marionette_client-0.8.7-py2.7.egg/marionette/marionette_test.py", line 283, in run
    testMethod()
  File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_change_language.py", line 31, in test_change_language_settings
    language_settings.select_language(lang_name)
  File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1/tests/python/gaia-ui-tests/gaiatest/apps/settings/regions/language.py", line 39, in select_language
    self.select(language)
  File "/var/jenkins/2/workspace/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1/tests/python/gaia-ui-tests/gaiatest/apps/settings/regions/language.py", line 64, in select
    raise Exception("Element '%s' could not be found in select wrapper" % match_string)
Exception: Element '\u01a4\u0227\u0227\u0188\u0137\u0227\u0227\u0260\u1e17\u1e17\u1e13 \u0226\u0227\u0188\u0188\u1e17\u1e17\u019e\u0167\u1e17\u1e17\u1e13' could not be found in select wrapper


http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1/54/testReport/junit/%28root%29/test_settings_change_language_py%20TestChangeLanguage_test_change_language_settings/test_settings_change_language_py_TestChangeLanguage_test_change_language_settings/

http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2/54/testReport/%28root%29/test_settings_change_language_rtl_py%20TestChangeLanguageRTL_test_change_language_settings_rtl/test_settings_change_language_rtl_py_TestChangeLanguageRTL_test_change_language_settings_rtl/


Environment Variables:
Device firmware (base) 	L1TC100118D0
Device firmware (date) 	27 Feb 2015 01:40:36
Device firmware (incremental) 	eng.cltbld.20150227.044026
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	26 Feb 2015 11:06:40
Gaia revision 	7512026a3772
Gecko build 	20150227010229
Gecko revision 	c7968255c1ea
Gecko version 	39.0a1


Repro Rate: 10/10 failures

Reproduces Manually: No
Reporter

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing]
QA Whiteboard: [QAnalyst-Triage?][fxosqa-auto-backlog?] → [QAnalyst-Triage+][fxosqa-auto-backlog?]
Flags: needinfo?(pbylenga)
Attachment #8573926 - Attachment is obsolete: true
Attachment #8573927 - Flags: review?(martijn.martijn)
Attachment #8573927 - Flags: review?(martijn.martijn) → review+
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
It seems like autolander doesn't support "leave-open".
Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
Please verify your Gaia Try runs before pushing in the future.
Assignee: nobody → jlorenzo
Filed Bug 1140669 to cover the impending xfail on-device only
Changing the summary to reflect that this covers two tests.
Summary: test_settings_change_language.py error; exception "Element '%s' could not be foundin select wrapper" → Error in both test_settings_change_language tests: exception "Element '%s' could not be foundin select wrapper"
Posted patch all.diffSplinter Review
These tests became even more broken with the pull request from bug 1217733.
This patch would fix that part, but in order to fix these tests, I would need to be able to select the item named "ᴚnuʇıɯǝ Ԑıpı".
I have no idea on how to do that, I don't even know what word that is (Runtime 31d1?)
It also looks like the 2nd to last select item and the last item have the same name. Is that what's wanted, Stas?
Flags: needinfo?(stas)
Screenshot of the select dialog with the developer locales enabled.
Wow, I'm sorry, this is a terrible case of search-and-replace gone wrong.

https://github.com/mozilla-b2g/gaia/commit/f03380e451eb2a33a27e7b30c183c311f8e7430d#diff-9413f92730386581ed79f16a649180fa

I don't even…

(In reply to Martijn Wargers [:mwargers] (QA) from comment #9)

> I have no idea on how to do that, I don't even know what word that is
> (Runtime 31d1?)

It's "Runtime Bidi".

> It also looks like the 2nd to last select item and the last item have the
> same name. Is that what's wanted, Stas?

That's weird, I'll take a look.
Flags: needinfo?(stas)
Comment on attachment 8683134 [details] [review]
[gaia] mwargers:1137766 > mozilla-b2g:master

Ok, this makes the test work again. At least, if the issue I mentioned in comment 9 would be resolved:
"
It also looks like the 2nd to last select item and the last item have the same name. Is that what's wanted, Stas?
"
It looks that "Runtime Accented" is currently not in the list of languages and "Runtime Bidi" is duplicated. Hopefully Stas will find out what the cause of that is.
I tested test_settings_change_language with the options of "Runtime Bidi" and then the test passes.

This code can be improved quite a bit (and I think the tests can be combined perhaps in a parameterized call perhaps), but I first want to get these enabled again. It's easier to improve the code with working tests.
Attachment #8683134 - Flags: review?(npark)
Attachment #8683134 - Flags: review?(jlorenzo)
Comment on attachment 8683134 [details] [review]
[gaia] mwargers:1137766 > mozilla-b2g:master

Looks good to me, but maybe we should hold off merging it until they fix the runtime Bidi duplication issue.
Attachment #8683134 - Flags: review?(npark) → review+
The tests are still disabled within the pull request.
Comment on attachment 8683134 [details] [review]
[gaia] mwargers:1137766 > mozilla-b2g:master

Looks good to me. I left one question in the PR.
Attachment #8683134 - Flags: review?(jlorenzo) → review+
(In reply to Autolander from comment #12)
> Created attachment 8683134 [details] [review]
> [gaia] mwargers:1137766 > mozilla-b2g:master

Merged this: https://github.com/mozilla-b2g/gaia/commit/e3de39f5fd8e2833959288619c72e73ab6d8b4a7
Assignee: jlorenzo → nobody
Was merged in comment 17
Status: REOPENED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.