Black picture in Firefox 36

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: dusty-2011, Unassigned, NeedInfo)

Tracking

({regression})

36 Branch
x86_64
Windows 8.1
regression
Points:
---

Firefox Tracking Flags

(firefox37 fixed, firefox38 fixed, firefox39 fixed)

Details

Attachments

(8 attachments)

(Reporter)

Description

3 years ago
Created attachment 8570919 [details]
black picture.png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150222232811

Steps to reproduce:

I opened this page:
http://gathering.tweakers.net/forum/list_message/43825316#43825316
The picture in this post (with the red-colored in-ear) loaded just fine.
Then I posted a response in the thread.
After posting the response I was automatically sent back to the thread.


Actual results:

The picture had become corrupt. There was a small line at the top of the picture that still looked OK. The rest of the picture had become solid black. See the attachment. Refreshing the page with F5 does not resolve this issue. The only way to resolve the issue is by refreshing the page while bypassing the browser cache with Ctrl+F5.


Expected results:

The picture of the red colored in-ear should have looked just fine.

I've had similar issues on other websites. Pictures became partially black, and I've had to press Ctrl+F5 to resolve it.

I don't recall ever having this problem with previous Firefox versions. As far as I can remember, I've only had this problem in Firefox 36. So this may be a regression.

My computer's specs are:
GPU: Nvidia Geforce GTX 970 with 347.52 drivers installed (latest version). Not overclocked.
CPU: Intel Core i5-4590. Not overclocked.
Crucial MX 100 512 GB SSD.
3 TB HDD.
Motherboard: Gigabyte Z97-D3H

It might be difficult to reproduce this problem. Still, I hope you can find the cause.

Comment 1

3 years ago
Cannot reproduce on FF36 on Fedora 21 with the given URL.

Does the problem still happen if you start Firefox in Safe Mode? (Safe Mode disables extensions and themes, hardware acceleration and some JavaScript stuff in order to exclude some possible reasons for problems. It does not disable plugins which are add-ons.) See http://support.mozilla.com/en-US/kb/Safe+Mode 

And does this also happen with a new and empty profile? See http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile and http://support.mozilla.org/kb/Managing%20profiles
Flags: needinfo?(dusty-2011)
(Reporter)

Comment 2

3 years ago
Created attachment 8571571 [details]
another example

Here's another example. I've had this page (http://nl.hardware.info/nieuws/43097/rockstar-geeft-nieuwe-screenshots-pc-versie-gta-v-vrij) open for a couple of days now. I've done several browser restarts (Shift+F2 type restart), and two pictures are not OK. One is partially black, the other is fully black. Refreshing the page with F5 does not resolve it. Switching to a different tab and then switching back does solve it. Refreshing the page and bypassing the cache with Ctrl+F5 should also solve it.

To be able to reproduce the bug you really have to use the browser for a long time. There's no magical steps I can give you that will lead to you reproducing the bug always.
(Reporter)

Comment 3

3 years ago
Created attachment 8572597 [details]
example 3

Example 3. I open http://tweakers.net/nieuws/ and scroll down the page. One of the pictures is black. If I then open that article in a new tab (http://tweakers.net/nieuws/101700/nvidia-komt-met-op-games-gerichte-settop-box-op-basis-van-android-tv.html) the picture remains black. The picture also remains black if I switch to a different tab and then back. But the picture loads correctly when I press Ctrl + F5.

Comment 4

3 years ago
See comment 1.
(Reporter)

Comment 5

3 years ago
I have verified this problem does exist in a fresh new profile.

What I did in my new profile was the following:
open http://tweakers.net/nieuws/ in a new tab
open http://nl.hardware.info/ in a new tab
open http://www.deviantart.com/ in a new tab, browse to http://www.deviantart.com/browse/all/ in this tab. Scroll down quite a lot.
open http://www.nu.nl/ in a new tab.
open http://getmusicbee.com/ in a new tab.
open http://www.gamespot.com/ in a new tab.
open http://www.gamespot.com/reviews/shelter-2-review/1900-6416055/ in a new tab.
Now return to the tab with http://www.deviantart.com/browse/all/ opened. Several of the pictures in this tab were partially or completely black.

Since the problem exists in a new profile, we can exclude any add-ons from being the cause.

I have tried to reproduce the problem in Safe Mode, both in my existing profile and in the new profile. I have failed to reproduce the problem in Safe Mode. So the main suspect is clear now: hardware acceleration.

I don't think there's anything wrong with my GTX 970 graphics card. I use it for a lot of recent games and they all run fine. No artefacts or crashes. All my desktop programs also run just fine with no crashes. My system is very fast and stable. The only issue is with Firefox, some pictures are partially black.

I use the latest display drivers from Nvidia (347.52). All my other drivers are also up to date. I've installed all Windows updates as well (running Windows 8.1 64-bits).

I have ran the hardware acceleration stress test at https://developer.mozilla.org/media/uploads/demos/p/a/paulrouget/8bfba7f0b6c62d877a2b82dd5e10931e/hacksmozillaorg-achi_1334270447_demo_package/HWACCEL/  and it ran just fine. The result was 60+ FPS. If I run this benchmark in Safe Mode (which has HWA disabled) I get 41 FPS.

This is what the graphics section of about:support reads (in the new profile, safe mode not enabled):

Adapter-RAM	4095
Adapter-RAM (GPU #2)	Unknown
Adapterbeschrijving	NVIDIA GeForce GTX 970
Adapterbeschrijving (GPU #2)	Intel(R) HD Graphics 4600
Adapterstuurprogramma’s	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapterstuurprogramma’s (GPU #2)	igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
Datum stuurprogramma	2-5-2015
Datum stuurprogramma (GPU #2)	10-9-2014
Device-ID	0x13c2
Device-ID (GPU #2)	0x0412
Direct2D ingeschakeld	true
DirectWrite ingeschakeld	true (6.3.9600.17415)
GPU #2 actief	false
GPU-versnelde vensters	1/1 Direct3D 11 (OMTC)
Stuurprogrammaversie	9.18.13.4752
Stuurprogrammaversie (GPU #2)	10.18.10.3977
Subsys-ID	00000000
Subsys-ID (GPU #2)	0000000c
Vendor-ID	0x10de
Vendor-ID (GPU #2)	0x8086
WebGL-renderer	Google Inc. -- ANGLE (NVIDIA GeForce GTX 970 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0


I think it's possible that this bug is only reproducable if you have an Nvidia GPU, or more specific only if you have a GTX 970 GPU. Perhaps it's even only present on some OS, or only some driver version etc. I hope you will look into this bug and find the cause.
Flags: needinfo?(dusty-2011)
(Reporter)

Comment 6

3 years ago
Created attachment 8575507 [details]
example of problem on deviantart

Here's a picture illustrating the issue on DeviantArt. This picture is not from the new profile, but the issue in the new profile was exactly the same.
(Reporter)

Comment 7

3 years ago
So, is someone looking into this bug? It's a quite annoying issue. Everytime a picture is (partially) black I have to refresh the page with Ctrl + F5. I have tried other browser (Internet Explorer 11, Chrome) and they do not have this issue.
Flags: needinfo?(a9016009)

Comment 8

3 years ago
Someone needs to be able to first reproduce the problem, I guess...

Comment 9

3 years ago
(In reply to Andre Klapper from comment #8)
> Someone needs to be able to first reproduce the problem, I guess...

It happens when you have lots tabs when image heavy sites open. Try opening lots of tabs, wait couple minutes and switch between them.
(Reporter)

Comment 10

3 years ago
(In reply to Night from comment #9)
> (In reply to Andre Klapper from comment #8)
> > Someone needs to be able to first reproduce the problem, I guess...
> 
> It happens when you have lots tabs when image heavy sites open. Try opening
> lots of tabs, wait couple minutes and switch between them.

Thank you for reproducing the bug! What hardware do you have? What operating system?

I have lots of tabs open at once. Right now I have 212 tabs open. But not all tabs are active. I've done a restart of the browser a few hours back, and only several dozen tabs are active. Memory usage of Firefox is below one gigabyte.

So the fact that I have a lot of tabs open at once might contribute to me facing this bug. A lot of those tabs also contain at least several images. And I often have a couple of DeviantArt tabs open with lots of images on them. And I do switch between tabs often. And I do switch between tabs after several minutes of using just one tab.

But per comment 5, in the new profile I was able to verify this bug with just 6 tabs open. One of them was very image heavy though, a DeviantArt page with at least several hundred pictures on it. But this shows that the bug should be reproducable with even a small number of tabs open. Even though the bug might be more easily reproduced with a lot of image heavy tabs open.

Comment 11

3 years ago
Created attachment 8578455 [details]
reddit-broken.png

Same here (see attached broken reddit header). Windows 8.1 x64, NVidia GeForce GTX 560 Ti, hardware acceleration is on. I noticed glitches after update to 36.0.1 - they appeared quite often, but after update to most recent 347.52 NVidia driver they seemed to gone - this one is the first in several days. 

If I try to open broken image in a new tab by its url it is still displayed with artifacts until completely reloaded with Ctrl+F5. If I save borken image to hard drive (right click - save image as) it is displayed in image viewer correctly.

Comment 12

3 years ago
Created attachment 8578457 [details]
reddit-actual.png

Attached correct reddit header image, just in case
(Reporter)

Comment 13

3 years ago
Thank you frymode! There are now at least three of us with this problem. And I'm sure there are many many other people with this problem, that just haven't found this bug yet.

I too started to notice this problem AFTER the update to version 36 or the update to version 36.0.1. I cannot remember if this problem existed before this update. But I'm sure that if the problem existed it was not common enough for me to notice, perhaps one broken image each month, but not like now. Now I see broken images every day (often several times each day).

That is why I think this is a regression. Solving this issue should start with getting a regression range. After that, the next step is either writing a fix for the problem, or simply backing out the patch that caused this regression in the first place.

Updated

3 years ago
Flags: needinfo?(a9016009)

Comment 14

3 years ago
I also have this problem, it started recently (within the last month)

There doesn't seem to be a reliable way to reproduce it, but I leave firefox running for long periods of time with lots of tabs open and regularly come across corrupted black images. Once corrupted, the images will stay corrupted even when opening a new tab with the same page, but a Ctrl+F5 fixes it. 

It's driving me mad!

I'm on Firefox 36.0.1, Windows 8 x64, NVIDIA GTX 560Ti.
(Reporter)

Comment 15

3 years ago
Yesterday I've updated my display drivers to the latest version: 347.88

I can still reproduce this problem with these latest Nvidia display drivers.
(Reporter)

Comment 16

3 years ago
Created attachment 8582003 [details]
partially white picture.png

Occassionally pictures become partially white instead of partially black, as can be seen in the attachment. This is as usual fixed with Ctrl+F5.

This is with the latest stable Firefox version installed, 36.0.4.
Created attachment 8582671 [details]
Screenshot_black_images_Android-resized.jpg

I believe I have the same problem on Firefox 36.0.4 for Android: on pages with many (heavy) images, some of them appear black, until the page is reloaded or Firefox put in background and reopened. I can always reproduce the bug when loading pages such as http://flight-report.com/fr/report-9741.html

On the French support forums, a user reports what seams to be the same problem with Firefox 36.0 on an Android tablet: http://forums.mozfr.org//viewtopic.php?f=32&t=123713
(In reply to Nicolas Turcot (:nico@nc) from comment #17)
> Created attachment 8582671 [details]
> Screenshot_black_images_Android-resized.jpg
> 
> I believe I have the same problem on Firefox 36.0.4 for Android...

As per https://bugzilla.mozilla.org/show_bug.cgi?id=1139430#c18 the issue on Android might be separate. I can actually not reproduce the issue on Firefox 37 beta.

Comment 19

3 years ago
FF 36.0.4 Win8.1 x64 NVIDIA GeForce GT 630 (Driver ver 347.88)

I also have this problem.
Component: Untriaged → Graphics
Flags: needinfo?(jmuizelaar)
Product: Firefox → Core
It's probably worth noting that it appears @dusty-2011's system is dual gpu:
> Adapterbeschrijving	NVIDIA GeForce GTX 970
> Adapterbeschrijving (GPU #2)	Intel(R) HD Graphics 4600

It's possible that this is a factor worth investigating. In particular whether the NVidia GPU or the Intel GPU are being used to render the images.

asd2003@gmail.com, can you please provide a copy of the Graphics section from your about:support page?
Duplicate of this bug: 1139430

Comment 22

3 years ago
> asd2003@gmail.com, can you please provide a copy of the Graphics section
> from your about:support page?

Аппаратно ускоренные окна	1/1 Direct3D 11 (OMTC)
Версия драйвера	9.18.13.4788
Визуализатор WebGL	Google Inc. -- ANGLE (NVIDIA GeForce GT 630 Direct3D9Ex vs_3_0 ps_3_0)
Дата разработки драйвера	3-13-2015
Драйвера видеокарты	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Код подсистемы	35441458
Код производителя	0x10de
Код устройства	0x0f00
Объём видеопамяти	2048
Описание видеокарты	NVIDIA GeForce GT 630
Direct2D включён	true
DirectWrite включён	true (6.3.9600.17415)
GPU #2 активен	false
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0


I try disable HW acceleration - no luck.
(In reply to asd2003 from comment #22)
> I try disable HW acceleration - no luck.

Thanks, can you try installing Firefox 35 to see if this is a regression? You'll find our old releases at ftp://ftp.mozilla.org/pub/firefox/releases/

Also, do you remember if you've installed any Windows updates recently? If so, it would be useful to identify those updates to us.

Comment 24

3 years ago
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #23)
> (In reply to asd2003 from comment #22)
> > I try disable HW acceleration - no luck.
> 
> Thanks, can you try installing Firefox 35 to see if this is a regression?
> You'll find our old releases at ftp://ftp.mozilla.org/pub/firefox/releases/
> 
> Also, do you remember if you've installed any Windows updates recently? If
> so, it would be useful to identify those updates to us.

I try FF 35.0, work fine, no black images.

About Win8.1 updates... All up 11.03.15
(In reply to asd2003 from comment #24)
> I try FF 35.0, work fine, no black images.

Thanks, can you try using http://mozilla.github.io/mozregression/install.html to narrow this down further?

Once installed, run the following command from a cmd.exe window:
> mozregression --good 2014-10-13

This will keep downloading Firefox builds and prompting you to tell it whether a build is good or bad. If you reproduce the bug, mark it "bad". If you don't, mark it "good". It will then move on to the next build. Once the range is narrowed it should give you a "Last Good", "First Bad", and pushlog. We'll need that pushlog to narrow down the change that caused this.


[Tracking Requested - why for this release]: I've nominated this to track not because QA can reproduce (we can't) but because anecdotal evidence provided by several users seems to indicate a hardware-specific regression.
Status: UNCONFIRMED → NEW
status-firefox37: --- → affected
status-firefox38: --- → affected
status-firefox39: --- → affected
tracking-firefox37: --- → ?
tracking-firefox38: --- → ?
tracking-firefox39: --- → ?
Ever confirmed: true
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 26

3 years ago
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #20)
> It's probably worth noting that it appears @dusty-2011's system is dual gpu:
> > Adapterbeschrijving	NVIDIA GeForce GTX 970
> > Adapterbeschrijving (GPU #2)	Intel(R) HD Graphics 4600
> 
> It's possible that this is a factor worth investigating. In particular
> whether the NVidia GPU or the Intel GPU are being used to render the images.

The Intel HD Graphics 4600 is just the integrated GPU of my Intel Core i5-4590 processor. I've never used this integrated graphics processor. My monitor is hooked up to my discrete GPU, the GTX 970. So I would naturally assume that my discrete GPU is rendering the images.

But if it is somehow possible that my integrated graphics is rendering the images, then enlighten me. I naturally assumed that my integrated graphics processor wasn't used at all.

But your observation about dual GPU was fully correct. It's good to keep that in mind in case it somehow affects this bug, even if it is not understood how it affects the bug.

Comment 27

3 years ago
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #25)
> (In reply to asd2003 from comment #24)
> > I try FF 35.0, work fine, no black images.
> 
> Thanks, can you try using
> http://mozilla.github.io/mozregression/install.html to narrow this down
> further?
> 
> Once installed, run the following command from a cmd.exe window:
> > mozregression --good 2014-10-13
> 

Done. All builds good. But this builds without settings and for complete test request more time for use every build.
(Reporter)

Comment 29

3 years ago
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #25)
> (In reply to asd2003 from comment #24)
> > I try FF 35.0, work fine, no black images.
> 
> Thanks, can you try using
> http://mozilla.github.io/mozregression/install.html to narrow this down
> further?
> 
> Once installed, run the following command from a cmd.exe window:
> > mozregression --good 2014-10-13
> 
> This will keep downloading Firefox builds and prompting you to tell it
> whether a build is good or bad. If you reproduce the bug, mark it "bad". If
> you don't, mark it "good". It will then move on to the next build. Once the
> range is narrowed it should give you a "Last Good", "First Bad", and
> pushlog. We'll need that pushlog to narrow down the change that caused this.
> 
> 
> [Tracking Requested - why for this release]: I've nominated this to track
> not because QA can reproduce (we can't) but because anecdotal evidence
> provided by several users seems to indicate a hardware-specific regression.

I've done this too. I could not reproduce the bug. I used every Nightly build for at least 10 minutes. I opened many different tabs all containing images. I browsed through hundreds of images at DeviantArt. I simply could not reproduce the bug. Whereas I easily reproduced the bug for Firefox 36.0.4 in a fresh profile. Here are my personal notes:

37.0a1 2015-01-05 GOOD  (everything works OK)

38.0a1 (2015-02-16  GOOD  (flash seems disabled, all videos are black boxes/pictures, but no bug, all pictures are fine)

39.0a1 (2015-03-09) GOOD (everything works OK)

39.0a1 (2015-03-20) GOOD (everything works OK)

39.0a1 (2015-03-25) GOOD (everything works OK)

39.0a1 (2015-03-28) GOOD (everything works OK)

39.0a1 (2015-03-29) GOOD (everything works OK)

39.0a1 (2015-03-27) GOOD (everything works OK)

39.0a1 (2015-03-27) GOOD (everything works OK)

I don't think it has created a pushlog.

Tomorrow I will have a look at the builds in comment 28, if I have enough time.
(Reporter)

Comment 30

3 years ago
I have tested all the builds of comment 28 with a fresh profile. I have tested each build for at least 10 minutes of heavy browsing. This should be plenty, with a fresh profile and release version 36.0.4. I can reproduce the bug within 2 minutes of heavy browsing (I have verified it at least 5 times, always within a few minutes of browsing).

1st: * ftp://ftp.mozilla.org/pub/firefox/nightly/2014/10/2014-10-13-03-02-02-mozilla-central/firefox-35.0a1.en-US.win32.installer.exe
GOOD, working ok.

2nd: * ftp://ftp.mozilla.org/pub/firefox/nightly/2014/10/2014-10-21-03-02-08-mozilla-central/firefox-36.0a1.en-US.win32.installer.exe

This nightly is completely broken, I can't use it at all. When I have this Nightly open all my other programs constantly lose focus. And the Nightly is so slow, it's like using a browser from 1995. I have ended Nightly with task manager. After opening Nightly again it has automatically upgraded to version 40. So far for this build. The build is completely broken but I cannot verify the bug (due to not being able to open websites).

3rd: * ftp://ftp.mozilla.org/pub/firefox/nightly/2014/10/2014-10-28-03-02-04-mozilla-central/firefox-36.0a1.en-US.win32.installer.exe
GOOD, working ok.

4th: * ftp://ftp.mozilla.org/pub/firefox/nightly/2014/11/2014-11-07-03-02-02-mozilla-central/firefox-36.0a1.en-US.win32.installer.exe
GOOD, working ok.

5th: * ftp://ftp.mozilla.org/pub/firefox/nightly/2014/11/2014-11-14-03-02-06-mozilla-central/firefox-36.0a1.en-US.win32.installer.exe
GOOD, working ok. Got lots of tab crashes but that's not relevant. After using it for 5 minutes Nightly completely crashed on me, had to end it with task manager. So I could not do further testing. This build is pretty broken but I did not see the bug.

6th: * ftp://ftp.mozilla.org/pub/firefox/nightly/2014/11/2014-11-20-03-02-02-mozilla-central/firefox-36.0a1.en-US.win32.installer.exe
GOOD, working ok. I've used this build for 20 minutes of heavy browsing without problems. I opened and closed several hundred image heavy pages without issues.

We aren't really making much progress towards solving this bug. All the builds that you want tested work just fine regarding this issue, i.e. the bug is not present. Whereas the bug is easily verified in a fresh profile in Firefox 36.0.4. release version.

I did notice that all the nightlies (except a few really old ones) use e10s. The release version of Firefox does not use e10s. Is it possible that that affects this bug somehow? I.e. that the bug is not reproducable with e10s enabled but is reproducable with e10s disabled. Just some speculation from my side.

Some more speculation. Can it be that this bug was introduced in the Beta or Aurora cycle of Firefox 36? Instead of in the Nightlies? It could be the case that some code from a nightly version was uplifted to beta or aurora without proper testing of that code on the beta or aurora version. And that that code was then released in the stable version.

Asd2003, please also test the builds in comment 28.
(Reporter)

Comment 31

3 years ago
I have upgraded to Firefox 37 (released today!) and done 30 minutes of very heavy browsing on image heavy websites. I have not been able to reproduce this bug. If the bug was still present in Firefox 37 I should have been able to reproduce the bug by now.

So, there's a good chance the bug is fixed with the release of Firefox 37. I recommend everyone that faces this bug upgrades to Firefox 37 right away. As a bonus, you'll finally get 60 fps videos on YouTube.
(In reply to dusty-2011 from comment #30)
> I have tested all the builds of comment 28 with a fresh profile. I have
> tested each build for at least 10 minutes of heavy browsing. This should be
> plenty, with a fresh profile and release version 36.0.4. I can reproduce the
> bug within 2 minutes of heavy browsing (I have verified it at least 5 times,
> always within a few minutes of browsing).
> 
> 1st: *
> ftp://ftp.mozilla.org/pub/firefox/nightly/2014/10/2014-10-13-03-02-02-
> mozilla-central/firefox-35.0a1.en-US.win32.installer.exe
> GOOD, working ok.
> 
> 2nd: *
> ftp://ftp.mozilla.org/pub/firefox/nightly/2014/10/2014-10-21-03-02-08-
> mozilla-central/firefox-36.0a1.en-US.win32.installer.exe
> 
> This nightly is completely broken, I can't use it at all. When I have this
> Nightly open all my other programs constantly lose focus. And the Nightly is
> so slow, it's like using a browser from 1995. I have ended Nightly with task
> manager. After opening Nightly again it has automatically upgraded to
> version 40. So far for this build. The build is completely broken but I
> cannot verify the bug (due to not being able to open websites).
> 
> 3rd: *
> ftp://ftp.mozilla.org/pub/firefox/nightly/2014/10/2014-10-28-03-02-04-
> mozilla-central/firefox-36.0a1.en-US.win32.installer.exe
> GOOD, working ok.
> 
> 4th: *
> ftp://ftp.mozilla.org/pub/firefox/nightly/2014/11/2014-11-07-03-02-02-
> mozilla-central/firefox-36.0a1.en-US.win32.installer.exe
> GOOD, working ok.
> 
> 5th: *
> ftp://ftp.mozilla.org/pub/firefox/nightly/2014/11/2014-11-14-03-02-06-
> mozilla-central/firefox-36.0a1.en-US.win32.installer.exe
> GOOD, working ok. Got lots of tab crashes but that's not relevant. After
> using it for 5 minutes Nightly completely crashed on me, had to end it with
> task manager. So I could not do further testing. This build is pretty broken
> but I did not see the bug.
> 
> 6th: *
> ftp://ftp.mozilla.org/pub/firefox/nightly/2014/11/2014-11-20-03-02-02-
> mozilla-central/firefox-36.0a1.en-US.win32.installer.exe
> GOOD, working ok. I've used this build for 20 minutes of heavy browsing
> without problems. I opened and closed several hundred image heavy pages
> without issues.
> 
> We aren't really making much progress towards solving this bug. All the
> builds that you want tested work just fine regarding this issue, i.e. the
> bug is not present. Whereas the bug is easily verified in a fresh profile in
> Firefox 36.0.4. release version.
> 
> I did notice that all the nightlies (except a few really old ones) use e10s.
> The release version of Firefox does not use e10s. Is it possible that that
> affects this bug somehow? I.e. that the bug is not reproducable with e10s
> enabled but is reproducable with e10s disabled. Just some speculation from
> my side.
> 
> Some more speculation. Can it be that this bug was introduced in the Beta or
> Aurora cycle of Firefox 36? 

That is certainly possible. You'd have to test each of the Firefox 36 Beta builds and a set of the Firefox 36.0a2 builds to confirm. Betas can be found here [ftp://ftp.mozilla.org/pub/firefox/releases/]. Auroras can be found here [ftp://ftp.mozilla.org/pub/firefox/nightly/] in folders dated between November 29, 2014 and January 12, 2015.

However, it's probably pointless to do further testing if what dusty has reported is true. Please try Firefox 37.0 and see if this resolves the issue.
If you originally observed this bug with e10s disabled then you should test with e10s disabled. It is quite likely that enabling e10s changes this significantly and you wouldn't see the bug.

Comment 34

3 years ago
I also have this issue, it mostly appears when I browse on image-heavy sites, with or without multiple tabs. Sometimes completely loaded tabs appear corrupted after switching back to them, sometimes pages from history are affected when navigating backwards. I haven't found actual steps that trigger the issue. Right now, an image in an article on Golem.de got corrupted. There were only two tabs open at that time.

Firefox version: 36.0.4 (build 20150320202338)

Basic system info:
16 GiB RAM
Windows 8.1 x64 (up to date as of now)

Graphics info from about:support:
--------

Adapter Description: NVIDIA GeForce GTX 670
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: 2048
Device ID: 0x1189
Direct2D Enabled: true
DirectWrite Enabled: true (6.3.9600.17415)
Driver Date: 2-5-2015
Driver Version: 9.18.13.4752
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 11 (OMTC)
Subsys ID: 26783842
Vendor ID: 0x10de
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 670 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

I'll test the current Firefox 37 beta.
(Reporter)

Comment 35

3 years ago
(In reply to Daniel B. from comment #34)

> I'll test the current Firefox 37 beta.

Please don't test the beta. Just test the stable release version of Firefox 37.

You can easily upgrade your Firefox version to version 37. Click on the hamburger menu, click on the help icon, click on About Firefox. Then it will automatically check for updates. When it's done downloading the update, click the button to restart the browser. Now you will have the release version of Firefox 37 installed.

Comment 36

3 years ago
(In reply to dusty-2011 from comment #35)
> You can easily upgrade your Firefox version to version 37. Click on the
> hamburger menu, click on the help icon, click on About Firefox. Then it will
> automatically check for updates.

That doesn't help when on the release channel, because Firefox 37 hasn't been completely rolled out yet. Thanks though, hadn't noticed it was released.

Anyway, the issue didn't occur on FF 37. I noticed how some images are downloaded again when navigating back. It's possible these are the image that would've been corrupted otherwise. So I guess this issue has been fixed, one way or another.
I'm going to close this as WORKSFORME given the anecdotal evidence from Daniel and Dusty. Please reopen this bug report if the issue returns using Firefox 37 or later.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 38

3 years ago
(In reply to Daniel B. from comment #36)
> (In reply to dusty-2011 from comment #35)
> > You can easily upgrade your Firefox version to version 37. Click on the
> > hamburger menu, click on the help icon, click on About Firefox. Then it will
> > automatically check for updates.
> 
> That doesn't help when on the release channel, because Firefox 37 hasn't
> been completely rolled out yet. 

Are you sure about that? I Always follow this procedure just a few hours after the final builds appear on the FTP channel. It Always immediately updates my Firefox version to the latest stable build. Just a few hours after the first news articles about a new version appear I'm already using the new version.

(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #37)
> I'm going to close this as WORKSFORME given the anecdotal evidence from
> Daniel and Dusty. Please reopen this bug report if the issue returns using
> Firefox 37 or later.

This is a good call. I've been using Firefox 37 all day now without issues. If this bug reappears I will certainly report back here.

If anyone else is still having trouble, please report here. The bug is fixed for me and Daniel B., but in theory it is possible that the bug still exists for some hardware configurations (this is just speculation). So, if you are still facing this bug, let us know.

Comment 39

3 years ago
Confirm 37 without black image bug.
I'm clearing the tracking requests given that this bug has been resolved.
status-firefox37: affected → fixed
status-firefox38: affected → fixed
status-firefox39: affected → fixed
tracking-firefox37: ? → ---
tracking-firefox38: ? → ---
tracking-firefox39: ? → ---
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.