Last Comment Bug 113808 - JSS3.1 crashes the server after about few 1000 connections.
: JSS3.1 crashes the server after about few 1000 connections.
Status: RESOLVED INVALID
:
Product: JSS
Classification: Components
Component: Library (show other bugs)
: 3.1
: Sun Solaris
: -- blocker (vote)
: 3.2
Assigned To: Jamie Nicolson
: somni
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-06 05:32 PST by swamy
Modified: 2002-04-22 15:38 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
sample source code that reproduces the problem (119.50 KB, application/octet-stream)
2002-02-25 13:00 PST, Jamie Nicolson
no flags Details

Description swamy 2001-12-06 05:32:49 PST
I'm using JSS3.1 api's to establish ssl between the client and the
server.When I try to simulate multiple requests to the server the SSL client
throws a SIGBUS 10 bus error after about few 1000 connections.

The following is the trace generated.

SIGBUS 10 bus error
   si_signo [10]: BUS
   si_errno [0]:
   si_code [1]: BUS_ADRALN [addr: 0xef40f765]

       stackpointer=EB1E06A0

Inconsistent thread : best efforts attempt (may fail)
"Thread-201" (TID:0x8ea580, sys_thread_t:0x8ea4b8, state:R, thread_t: 
t@229, threadID:0xe9241d78, stack_bottom:0xe9242000, stack_size:0x20000) 
prio=5

Inconsistent thread : best efforts attempt (may fail)
"HTTPSConnectionManager.listen()" (TID:0x828558, sys_thread_t:0x828490, 
state:R, thread_t: t@228, threadID:0xe92a1d78, stack_bottom:0xe92a2000, 
stack_size:0x20000) prio=5

[1] org.mozilla.jss.ssl.SSLServerSocket.socketAccept(Native Method)
[2] org.mozilla.jss.ssl.SSLServerSocket.accept(SSLServerSocket.java:133)


Inconsistent thread : best efforts attempt (may fail)
"HTTPSConnectionManager.listen()" (TID:0x828558, sys_thread_t:0x828490, 
state:R, thread_t: t@228, threadID:0xe92a1d78, stack_bottom:0xe92a2000, 
stack_size:0x20000) prio=5

[1] org.mozilla.jss.ssl.SSLServerSocket.socketAccept(Native Method)
[2] org.mozilla.jss.ssl.SSLServerSocket.accept(SSLServerSocket.java:133)
Comment 1 Jamie Nicolson 2002-01-31 13:27:33 PST
Is this still occurring? Can you please provide more detail:

1. You say that the client is crashing, but the stack trace mentions
Socket.accept(), which would normally be called by the server.

2. In your test, I assume you are passing some data between the client and server?

3. What operating system is this happening on? Solaris 2.?

4. Optimized or Debug build?

The best way for me to reproduce this is if you could give me some sample code
that  reproduces the problem.
Comment 2 Jamie Nicolson 2002-02-25 12:59:21 PST
Hi,

1. You say that the client is crashing, but the stack trace mentions
Socket.accept(), which would normally be called by the server.

We have a gateway which acts both as client and server.
As you said the gateway crashes at the SSLServerSocket accept().

2. In your test, I assume you are passing some data between the client and server?

In my test the following are the components.
 1. Client (browser)
 2. Gateway (SSL Server)
 3. Web server(Optionally SSL Server)

3. What operating system is this happening on? Solaris 2.?
we are using solaris 8

4.Optimized or Debug build?

Optimized build


I'm also forwarding you the mail with sample source code to reproduce the
problem. [ATTACHED TO BUG]
If you stress test you will see the COre Dump after about 90 minutes.

Comment 3 Jamie Nicolson 2002-02-25 13:00:21 PST
Created attachment 71341 [details]
sample source code that reproduces the problem
Comment 4 Jamie Nicolson 2002-04-16 10:26:03 PDT
Glen wrote:

I switched to 1.3.1_01 JVM and the thread count for the Gateway process did not
grow. I had a load of 150 users running last night for about 12 hours, so the
problem was the JVM. During the test I did have around 40 TCP connection reset
errors, but no SIG_BUS error. I got Swamy to start testing well, and he had no
problem after three hours. He is doing some more load testing and will get back
to me, but the SIG_BUS problem should be solved.
Comment 5 glen beasley 2002-04-22 15:18:35 PDT
In addition to using JDK 1.3.1 or greater you also should upgrade to JSS 3.1.2 
due to a SSL memory leak fix. 
Comment 6 Jamie Nicolson 2002-04-22 15:38:05 PDT
The problem was fixed by upgrading to JDK 1.3.1. This was not a bug in JSS.

Note You need to log in before you can comment on or make changes to this bug.